IBM Support

A "CWLLG0095W: The repository contact failed with a status of: 302" error occurs with IBM Business Process Manager (BPM)

Troubleshooting


Problem

When the Process Server tries to connect to the Process Center repository, the following warning message might occur in the SystemOut.log file:

CWLLG0095W: The repository contact failed with a status of: 302

Symptom

The CWLLG0095W message is logged every 10 seconds in the SystemOut.log file. This value is the default heartbeat time that is used by the Process Server to check for updates on the Process Center repository. However, the Process Center repository cannot be reached, in this case, and the warning message is logged.

Cause

The two most common reasons for this warning are:

  1. The authentication alias, which is defined on the Process Server side for a user to connect to the Process Center repository, refers to an alias that has incorrect credentials specified in either the Process Server or Process Center security configuration. The user and password set in the alias must be present in the Process Center configuration.
  2. HTTPS is set as the default for communication from Process Center to Process Server. If you are running on HTTP and have not configured this correctly, you might also see the warning message.

Diagnosing The Problem

For IBM Business Process Manager versions prior to V8.5.x:

Check the <repository-server-user-auth-alias> value that is defined in your Process Server. You can find the currently set user and password value in the TeamWorksConfiguration.running.xml file, which is located in the install_root/profiles/profile_name/config/cells/cell_name/nodes/node_name/servers/server_name/process-server directory. The install_root, profile_name, cell_name, node_name, and server_name variables are specific to your environment.

Compare these values with the appropriate Java™ 2 Connector (J2C) authentication alias ("Authentication alias for the IBM Process Center connection.") in the administrative console of your Process Server and Process Center. You can find this configuration at


Security > Global Security > Authentication > Java Authentication and Authorization Service > J2C authentication data

The following screenshot shows this administrative console panel:


For a larger image, see the following attachment:


For IBM Business Process Manager V8.5.0.x and later:
The <repository-server-user-auth-alias> value does not exist. The authentication alias is modified using the Integrated Solutions Console. It is mapped to the ProcessCenterUser role to connect the Process Center to the Process Server. By default, the authentication alias defaults to the DeAdmin authentication alias.
Check the DeAdminAlias and ProcessCenterUserAlias at Security > Global Security > Authentication > Java Authentication and Authorization Service > J2C authentication data
and ensure that they are set correctly.

Resolving The Problem

  1. Enter the correct administrative level credentials for the authentication alias that is used for the communication with the Process Center. This approach solves the connection issue and the warning message does not display.
  2. Ensure that you are using HTTPS. If you need to run with HTTP, check that it is configured correctly. See the Knowledge Center for more details.

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Product Synonym

BPM

Document Information

Modified date:
21 December 2018

UID

swg21580089