IBM Support

Configuration Process Did Not Change to COMP Status

Troubleshooting


Problem

The activity status has been changed to COMP but its parent process remains INPRG.

Symptom

Overview:

When a task has its status changed to Complete, the next task status
automatically gets the status In Progress.

After the last task is implemented (task owner changes its status to
Complete), the Configuration Process Record status should automatically
be changed to Complete.

The problem is, that if this doesn't occur, the Configuration Process
Record remains in In Progress status.

STEPS:
1. Create a new condition called YWOABTNCLOSE in the Conditional Expression Manager application.



2. Go to the Security Groups application and bring up the Everyone security group.
Go to Activities and Tasks application.
Grant access to the Complete Activity option.
Attach the YWOABTNCLOSE condition to the Complete Activity option.


3. Go to IT Infrastruture application > Process Request application.
Create a new process request:
process manager type = Configuration
enter a configuration item
enter a classification e.g. PMCFGUR.



4. Click the Submit icon on the toolbar:


Process state changed to submitted:


5. Click the Accept icon on the toolbar:



Process state is submitted and the status changed to INRPG:


6. Go to the Related Records tab
A new work order 1060 has been created in the related work orders section:



7. Go to the Configuration Processes application and
bring up work order 1060:



Under flow control chec-kbox (on the right) is checked by default:



Check the "Inherit Status" check-box:



8. Go to the Pans tab:
job plan = UPDATECI
Go to task 10
Populate the owner field with MAXADMIN
Delete task 20,30,40,50
Save

9. Click the "Change Status" icon on the toolbar and change the status to INPRG
Go to the Plans tab, click the change status icon on task 10.
Change the status of the task work order to INPRG.

10. Click the arrow next to task 10 to expand task 10 and then click on the arrow next to reference WO 1132. Hyper-link to the Activities and Tasks application:



11. Click on the "Complete Activity" button and change status dialog box comes up.
Click OK and the status of the activity has changed to COMP:



12. Click the return link to return to the "Configuration Processes" application search for the same configuration process 1060.

The Configuration process record remains INRPG even though its task work order has been COMPLETED:

Cause

The custom condition specifies a where clause status that does not exist for PMCFGWO and CHANGE work order class type and it will fail.

Diagnosing The Problem

The condition blocks the steps to complete the work order

Resolving The Problem

There are various work order classes for workorder object. Run the query below to determine which woclass needs to be filtered in the condition:

select DISTINCT(woclass) from workorder

steps:
1. Go to the Conditional Expression Manager application.
2. Bring up the custom condition and change the expression to the following:

((:status = 'INPRG' and :&PERSONID& = :OWNER)
or :woclass in ('PMCFGWO','CHANGE'))

The system now automatically changes the configuration process status to COMP when its activity has been changed to COMP status.

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Document Information

Modified date:
17 June 2018

UID

swg21579617