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** Troubleshooting ** Blank / empty / white "CAM User" field inside "Maintain - Rights Users"

Troubleshooting


Problem

User launches Controller, and clicks "Maintain - Rights - Users". User may or may not receive an error message at this point. User selects/highlights a user (for example "Smith, John"). Inside this user's "CAM User" section, it appears that this is empty/blank/white/unconfigured. * In other words, it does NOT contain the expected entry (for example "NAMESPACE\SmithJ").

Symptom

Controller does not appear to be able to successfully read the contents/list of users inside "Controller Users" group in Cognos security namespace.

In addition, in some situations:

  • The user clicks on the CAM User 'browse' button (...).
    • As expected, this will successfully shows MANY different 'CAM User' people to choose from.
  • Afterwards, user clicks "Cancel" (red cross).
    • Now, when selecting/highlighting a user you can now see that ALL users have got their "CAM User" successfully filled in (they are no longer white / blank).
  • However, if you create a NEW user (inside Controller) and then click on the CAM User 'browse' button (...), you can only see very few (e.g. one) user to choose from.
    • In other words, it *appears* that the membership of the Cognos 8 namespace security group "Controller Users" has suddenly lost most of its members (for example only 1 to choose from, when before there may have been 20 possible candidates to select).

Cause

There are several possible causes for the "CAM User" field being blank/white:

  • Scenario #1 - Cognos 8 security is configured to use a 'slow' namespace
    • For more information, see separate IBM Technote #1361744.
  • Scenario #2 - "Controller Administrators" contains a 'bad' group
    • For more information, see separate IBM Technote #1361744.
  • Scenario #3 - Invalid/corrupt user(s) inside "Controller Users" or "Controller Administrators" group(s).
    • For example, in one real-life case, the customer's users had both a "global" and a "UK" Windows (Active Directory) user account. Unfortunately, for one user the "wrong" version of the user account was inside the Cognos security group.
  • Scenario #4 - Limitation of Controller where duplicate user names (e.g. John Smith) used in multiple different Windows domain entries (e.g. DOMAIN1\JohnSmith and DOMAIN2\JohnSmith) inside "Controller Users" and/or "Controller Administrators"
    • For more information, see separate IBM Technote #1620794.

Environment

Controller configured to use Cognos 8 security (i.e. not the default 'Native' security).

Resolving The Problem

Scenario #1 & #2

See separate IBM Technote #1361744.

Scenario #3

Remove erroneous/unnecessary users from the Cognos security groups.

For example, in one real-life

  • Remove the 'bad' user account from the security group (in their case, the "Controller Administrators" group)
  • Add (into the same group) the same user, but this time (when browsing through the Active Directory) choosing the 'correct' version of their user account (in their case, it was the domain Global account).
  • Steps to troubleshoot Scenario #3:

    1. Obtain a short period of downtime (no users on system)
    2. Logon to Cognos Connection (http://servername/cognos8)
    3. Click on 'Security' tab
    4. Open 'Cognos' namespace
    5. Open each group (especially "Controller Users" and "Controller Administrators") in turn, and make a note of all the users
    6. As a precaution, create a backup of the ContentStore database
    7. Search for strange-looking users (or ones that should not be there) and experiment by removing them from the group(s)
    8. Test to see if problem resolved
    9. Repeat steps 7-8 until find the user(s) which are the root cause.
    10. Finally, add all the 'correct' users back into the relevant groups.

Scenario #4

Remove erroneous/unnecessary users from the Cognos security groups.

  • For more information, see separate IBM Technote #1620794.

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Document Information

Modified date:
15 June 2018

UID

swg21578394