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Random timeouts after configuring LDAP

Troubleshooting


Problem

Users randomly logged out while working in the application.

Symptom

Users are logged out while working in the application before the timeout value in set in web.xml.

Cause

This can be caused by the LTPA timeout values in WebSphere when user authentication is handed with Application Server Security (LDAP Authentication).

Diagnosing The Problem

 Have users time when they are logged in compared to the random logout time. This can be synchronized with the value of time the LTPA timeout is set for. You can also check SystemOut logs; there can be token session timeout messages written to it.

Resolving The Problem

1) Choose Global Security.
2) Click LTPA.
2) Look for the LTPA timeout value

The timeout setting is set to 120 minutes by default. If left at this value, when the token expires, a user will be logged out of Maximo, even when

3) Increase this value to a limit that suits your users
4) Stop the Maximo application server.
5) Synchronize nodes
6) Start the Maximo application 

*Note if you increase the value to a higher value than the timeout value in web.xml, users will still be logged due to inactivity.

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Document Information

Modified date:
26 March 2020

UID

swg21577219