IBM Support

Error message upon login to IBM DOORS: Invalid username or password

Troubleshooting


Problem

You receive error message "Invalid username or password" when you log in to IBM DOORS with the reset temporary Administrator password.

Symptom

You forget the DOORS administrator password.  Then, you follow the technote 1324457: How to reset the Administrator password in IBM ERM DOORS to generate the V2 key for the one-time Administrator password. However, you receive the "Invalid username or password” error when you try to log in to DOORS with user Administrator with the one-time password.

Cause

The database password is set. By default the password for the database is not set. However, a DOORS administrator can set the database password with the DOORS Database Server Admin tool (DBAdmintool). Setting the database password can prevent unauthorized users from resetting the Administrator's password.

Environment

Windows

Diagnosing The Problem

DOORS administrator forgets the password, resets the password with the V2 key, receives error message "Invalid username or password" upon the attempt to log in to DOORS with the reset one-time Administrator password.

Resolving The Problem

There are three ways to fix this issue.
  1. Reset the Administrator's password with the database password:
    Follow the technote 1324457: How to reset the Administrator password in IBM ERM DOORS and make sure that the database password is added in the quotation marks at the end of the password switch.
    For example, -otdbpw "DBpassword".
  2. Remove or reset the DOORS Database password before resetting the Administrator's password:
    1. Make sure that all DOORS users are logged out
    2. Stop the DOORS Database service from Windows Services
    3. Navigate to the DOORS installationDir\data. The default location of DOORS data folder is: C:\Program Files\IBM\Rational\DOORS\data
    4. Rename the dbdata.dtc file to dbdata.dtc.old
    5. Restart the DOORS Database service to remove the Database password and reset the Database password by using the DOORS Database Server Admin Tool
  3. When there is a second DOORS database with a known Administrators password, contact IBM support team to get assistance with the steps to replace the u0000000000000001.dtc file with a known password.

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Document Information

Modified date:
09 June 2023

UID

swg21576495