Troubleshooting
Problem
Customer upgrades Controller 10.1 via an IFx patch (for example upgrades from Controller 10.1 RTM to 10.1 IF2). However, the required dll 'FrCrypto.dll' is not registered on the application server, causing issues such as those seen in Technote 1454989.
Symptom
See separate Technotes such as 1454989.
Cause
Code production problem (APAR PM53881) in the Interim Fix (IF) patches for Controller 10.1.x, where the installer process does not register 'FrCrypto.dll' correctly.
Resolving The Problem
Fix:
Upgrade to Controller 10.1.1 FP1 (10.1.1671) or later.
Workaround:
Manually re-register the component FrCrypto.dll.
Steps:
- Logon to Controller application server as an administrator
- Launch a command prompt by clicking "Start" - "Run" and then typing in "CMD" <Enter>
- Change directory to the c10\common folder (for example using: cd "C:\Program Files\ibm\cognos\c10\common")
- Register the file using: regsvr32.exe FrCrypto.dll
- Test.
Related Information
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
15 June 2018
UID
swg21574744