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How to correctly use the Process Engine case-insensitive "PEV" views with Business Process Framework

Question & Answer


Question

What is the best way to generate and configure Process Engine case-insensitive views for Business Process Framework?

Cause

The Configuring Process Engine case-insensitive view support topic in the IBM FileNet Business Process Framework Installation Guide does not adequately document how to generate Process Engine case-insensitive views and configure Business Process Framework (BPF) to use them. If you are using a DB2 or an Oracle database server, do not follow the documentation recommendation to manually edit the Process Engine case-sensitive VWV views to make them case-insensitive. Manual editing of the VWV views can cause malfunctions in the Process Analyzer.
The BPF documentation is available here: https://www.ibm.com/support/pages/node/319223.

Answer

If your BPF system uses a DB2 or an Oracle database server and runs with the PA product, perform the following steps:
  1. Verify you upgraded to the following fix-pack levels:
    • BPF-4.1.0-003 or later
    • Process Engine 4.0.3 or later
    • Process Analyzer 4.0.3 or later
  2. Implement Process Engine case-insensitive PEV views for all PE queues that are mapped to BPF in-baskets in BPF Explorer. For more information, see the createDBviewsCl topic.
  3. Use BPF Explorer to configure BPF to operate with the case-insensitive PEV views. For more information, see the Updating queue names for case-insensitive views topic.


Recommendation
It is recommended that in Process Engine queues that are mapped to BPF in-baskets you create the following views:
  • Process Engine case-sensitive VWV views for Process Analyzer
  • Process Engine case-insensitive PEV views for BPF


Example
In the following example, a customer is configuring PEV views with BPF by following the procedure above:
  • A user with an existing case-sensitive view, VWVQ123_CaseManagement, creates a new case-insensitive view, PEVQ123_CaseManagement, to match the existing case-sensitive view by using vwtoolwith the createDBviewsCI command.

    See the createDBviewsCI topic for more information.
  • Then in BPF Explorer, the user navigates to the BPF internal definition of the view under Workflow Configuration > Queues > [QueueName]to edit the Object name field.

    Note: In the following screen shot, the queue name is CaseManagement.

  • Then, the user changes the Object name from f_sw.VWVQ123_CaseManagement to f_sw.PEVQ123_CaseManagement. The user clicks Apply to save the change, exits BPF Explorer, and restarts the application server. After the server is restarted, BPF uses the new case-insensitive "PEV" view to access the queue.


Important
If your system does not use Process Analyzer or if your system uses Process Analyzer with a Process Engine database on Microsoft SQL, you do not need to generate and use case-insensitive PEV views. Instead, use the traditional BPF workaround and manually modify the VWV DDL definitions in the Process Engine database to remove the double quotation marks from the column aliases. For more information, see the Updating Process Engine database views topic.

[{"Product":{"code":"SSNVLC","label":"FileNet Business Process Framework"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"--","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"4.1.0","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSNVLC","label":"FileNet Business Process Framework"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
26 April 2021

UID

swg21568463