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Connect:Direct UNIX File Agent will not start after server hardware upgrade

Troubleshooting


Problem

Connect:Direct UNIX File Agent will not start after server hardware upgrade

Symptom

Did an upgrade for AIX/IBM system power 5 to power 6 and File Agent version 1.2.01 running under Connect:Direct UNIX version 3.8.00 will not start

Error Message

$ cdfa
Error: could not find libjava.so
Error: could not find Java 2 Runtime Environment

Resolving The Problem

Cause:
After the upgrade was performed there was an issue with the AIX security setting on File Agent's install directory /usr/cdunix.
There was a more strict site standard umask setting of 027 than the default one of 022.

When moving the workload from one old server to the new hardware, a savevg and restvg which automatically re-created the file systems and restored data. However, due to the 027 setting, the mount point of /usr/cdunix was 750 (drwx-r-x---).

It became hidden when the file system mounted, and even changed the permission of /usr/cdunix to 755, the underneath mount point didn't change then caused the problem.

Fix:
umount /usr/cdunix, change the permission of /usr/cdunix to 755 then mount it again.

[{"Product":{"code":"SSKTYY","label":"IBM Sterling Connect:Direct for UNIX"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"All","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Historical Number

NFX8206

Product Synonym

[<p><b>]Escalation ID[</b><p>];134893

Document Information

Modified date:
24 July 2020

UID

swg21554912