IBM Support

How should I uninstall the Guardium GIM agent and all modules on the DB server.

Troubleshooting


Problem

How should I uninstall the Guardium GIM agent and all modules on the DB server.

Cause

Current documentation in IBM InfoSphere Guardium Version 8.0 Guardium Installation Manager and earlier do not have clear instructions for un-installing the GIM agent and all modules.

This lack of documentation is being addressed in the next major release of the documentation

Resolving The Problem


1. As user root check the /etc/inittab

    Make sure the gim and supervisor (gim and gsvr) entries are NOT commented out with a hash (#) symbol at the start of the line. If either of them are commented out, uncomment them , save the /etc/inittab file and issue the command
      init q

    2. From a directory that is not within the guardium installation directory :
      as user root run the uninstall.pl using the full path prefix
        <gim install dir>/GIM/current/uninstall.pl
      for example
        /usr/local/guardium/modules/GIM/current/uninstall.pl

    3. If the script prompts you to reboot the system (usually when STAP is installed), restart the system in the following way - depending on the platform

            O/SCommand
            Linuxshutdown -r
            SuSereboot
            HP-UXshutdown -r
            Solarisshutdown -i 6
            AIXreboot
            Tru64reboot

    [{"Product":{"code":"SSMPHH","label":"IBM Security Guardium"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"}],"Version":"8.0","Edition":"All Editions","Line of Business":{"code":"LOB24","label":"Security Software"}}]

    Document Information

    Modified date:
    16 June 2018

    UID

    swg21512709