IBM Support

When the Transactions T5 agent is installed, the WAS YN agent stops working.

Troubleshooting


Problem

When the Transactions T5 agent is installed, the YN agent stops working

Symptom

The YN agent will not start after the Transactions T5 agent is installed.

Cause

This is caused due to the T5 agent and the order in which it is installed. The T5 agent clobbers the JRE and over-writes it.

Environment

AIX 6.1 TL-4 64-bit

Resolving The Problem

To resolve the problem follow these steps:

* Uninstall the WAS YN agent as follows:

cd $ITM_HOME/bin

./uninstall.sh

* stop the Transaction T5, TU, TO agents, preferably in that order.

* Then re-install the WAS YN agent.

This order will preserve the JRE directory and the WAS YN agent will be able to start successfully.

[{"Product":{"code":"SSDTFJ","label":"Tivoli Composite Application Manager for Application Diagnostics"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"ITCAM for APPLICATION DIAGNOSTICS Agent for WebSphere","Platform":[{"code":"PF002","label":"AIX"}],"Version":"7.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

ITCAM ITCAM4AD ITCAMfAD ITCAM for App Diag Application Diagnostics WSAM

Document Information

Modified date:
17 June 2018

UID

swg21507795