IBM Support

"Standard Error ... 5 ... Object variable or With block variable not set" when use "Reports - Run" with DB2 database

Troubleshooting


Problem

User clicks "Reports - Run". User selects choices, and clicks "Preview". An error message appears.

Symptom

Screen
Information
Standard Error
Number: 5
Source: FrangoDirect.ExcelLinkD.FetchValues#ControllerProxyClient
Description: Ssytem.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.ArgumentNullException: Object variable or With block variable not set.
at
Cognos.Controller.Proxy.CCRWS.ExcelLinkB_FetchValues(String....
<...>
[OK}

Event Viewer (Application Log) on Windows 2008 64-bit using Office 2007:


Log Name: Application
Source: Cognos Controller
Date: 04/07/2011 08:20:59
Event ID: 0
Task Category: None
Level: Warning
Keywords: Classic
User: N/A
Computer: PCNAME
Description:
Standard Error
Number: 5
Source: FrangoDirect.ExcelLinkD.FetchValues#ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.NullReferenceException: Object variable or With block variable not set.
at Cognos.Controller.Proxy.CCRWS.ExcelLinkB_FetchValues(String sGuid, DataSet rsKeys, String sMcurr, Boolean bLocLang, String sUser, String sRep, Boolean bIsLnk, String sSortOrd, Int32 lOptBitSet)

Cause

DB2 feature "Operating system security for DB2 objects" is enabled

Environment

Controller application server based on Windows 2008 R2 (64-bit).

Resolving The Problem

Either:

  1. Disable the DB2 feature "Operating system security for DB2 objects" on the Controller application server
  2. or simply add the group "Everyone" to the local group "DB2USERS" on the Controller application server, and reboot the server.

Steps:

Method #1 - Disable the DB2 feature "Operating system security for DB2 objects"


    This is achieved by uninstalling the DB2 client, and then re-installing it, but during the installation wizard untick the option "Enable operating system security"
    1. Obtain a short period of downtime
    2. Logon to the Controller application server as an administrator
    3. Open "Control Panel" and click "Uninstall a program"
    4. Rightclick "IBM Data Server Client - DB2COPY1" and choose "Uninstall"
    5. After the wizard has finished, reboot the application server
    6. Launch the DB2 32-bit client installation wizard (setup.exe)
    7. Inside the "Select the installation type" choose "Custom"
    8. Accept all the defaults *except* inside the "Enable operating system security for DB2 objects" untick the option "Enable operating system security"
    9. Finish the wizard
    10. Test.

Method #2 - add the group "Everyone" to the local group "DB2USERS"


    To perform this:
    1. Logon to the Controller application server as an administrator
    2. Right-click on "My Computer" and choose "Manage"
    3. Open section "Configuration - Local Users and Groups - Groups"
    4. Double-click on group "DB2USERS"
    5. Click "Add"
    6. Type in "Everyone"
    7. Click OK, OK
    8. Obtain a short period of downtime, and reboot application server.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21504470