IBM Support

r3batch method Timer expired / System call timed out

Troubleshooting


Problem

Launching SAP job via TWS for Applications r3batch method it fails with generic error:
For LINUX: *** ERROR 552 *** 2011-05-20 13:49:05.174+02:00 Timer expired
For AIX: System call timed out

Symptom

When performing actions such selecting from a pick list, submitting a job, or similar actions that require connection to the SAP system, it returns the following error:
*** ERROR 552 *** 2011-05-20 13:49:05.174+02:00 Timer expired for LINUX machine
2020-08-05 17:31:44.566+01:00 System call timed out for AIX machine

Cause

Issue related to CCLog.

Diagnosing The Problem

Resolving The Problem

As a workaround, add the following entry in the r3batch.properties file:

r3batch.trace.tracers.logging=FALSE

This setting will disable the r3batch trace file that is active by default
- OR -
Comment out the r3batch.trace.handlers.traceFile.MPFileSemKeyproperties line
- OR -
Change the value of r3batch.trace.handlers.traceFile.MPFileSemKeyproperties to any number

Related Information

[{"Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSTG2Y","label":"Tivoli Workload Scheduler for Applications"},"ARM Category":[{"code":"a8m0z0000001epbAAA","label":"Documentation->R3batch"}],"ARM Case Number":"TS003980681","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"All Version(s)"},{"Line of Business":{"code":"LOB45","label":"Automation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Product":{"code":"SSGSPN","label":"IBM Workload Scheduler"},"ARM Category":[{"code":"a8m50000000L34rAAC","label":"Components->FTA->Xagent \/ methods"}],"Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"}],"Version":"9.3.0;9.4.0"}]

Historical Number

TS003980681

Product Synonym

TWS4APPS; TWS for Applications; TWS; IWS;

Document Information

Modified date:
03 September 2020

UID

swg21503284