IBM Support

An IBM Process Center server cannot be created in IBM Integration Designer

Troubleshooting


Problem

Any attempt to automatically or manually create a new Process Center server in Integration Designer fails with an exception.

Symptom

When you import a process application into the Integration Designer workspace, the process application imports successfully but a new Process Center server fails to be automatically created. If you attempt to manually create a new Process Center server using the New Server wizard, the wizard does not allow you to completely specify the properties required to create the new Process Center server.

In the Server Logs view of Integration Designer, the following exception is displayed:

com.ibm.ws.webcontainer.servlet.ServletWrapper service SRVE0068E: Uncaught exception created in one of the service methods of the servlet BPMRepoApp in application IBM_BPM_Teamworks_star8Node01_server1. Exception created : java.lang.NumberFormatException: For input string: "XXXX"

Cause

An offline server exists in the Process Center, which prevents the creation of a new Process Center server in Integration Designer.

Resolving The Problem

In the Servers tab of the Process Center, delete any offline servers. This will enable new Process Center servers to be created either automatically or manually in Integration Designer.

[{"Product":{"code":"SSTLXK","label":"IBM Integration Designer"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Troubleshooting","Platform":[{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.5.1.2;7.5.1.1;7.5.1;7.5.0.1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

IID

Document Information

Modified date:
15 June 2018

UID

swg21502855