IBM Support

"HTTP 404 Not Found" error when getting HTDS WSDL for ruleset

Troubleshooting


Problem

The error "HTTP 404 Not Found: The webpage cannot be found" is seen when accessing the HTDS (Hosted Transparent Decision Service) WSDL for a ruleset from the Rule Execution Server console.

Symptom

In the Rule Execution Server console, clicking on the link "Get HTDS WSDL for this ruleset version" for a ruleset belonging to a deployed RuleApp leads to an "HTTP 404 Not Found" error.

Cause

This error occurs when the HTDS (Hosted Transparent Decision Service) application for JRules has not been installed on the application server.

Resolving The Problem

To be able to use the HTDS feature, please install HTDS application (jrules-res-htds-<appserver>.ear or jrules-res-htds-<appserver>.war) on your application server.

You can find the jrules-res-htds-<appserver>.ear or jrules-res-htds-<appserver>.war in the directory <JRulesInstallDir>\executionserver\applicationservers\<AppServer>.

[{"Product":{"code":"SS6MTS","label":"WebSphere ILOG JRules"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Modules:Execution Server (BRES \/ RES)","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF012","label":"IBM i"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"},{"code":"PF025","label":"Platform Independent"}],"Version":"7.1;7.0;6.7","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}},{"Product":{"code":"SSQP76","label":"IBM Operational Decision Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"8.8;8.7;8.6;8.5;8.0;7.5","Edition":"Enterprise","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21501332