IBM Support

Stand-alone profile creation and nonworking JAX-WS API query calls
in the IBM Business Process Manager Advanced runtime server

Troubleshooting


Problem

Stand-alone profile creation for the IBM Process Center or IBM Process Server can lead to nonworking JAX-WS application programming interface (API) query calls in the runtime server.

Symptom

An exception occurs when query and queryAll calls are made to the JAX-WS API of the runtime server. An FFDC entry is created on the server side, which indicates the exception.

Cause

Execution of the applyPerfTuningTemplate.py performance tuning script, which is located in the <install-root>/scriptLibraries/ perfTuning/V70/ directory, implies a JAXB performance setting that, at run time, leads to a failure in JAXB marshalling. As a consequence, the execution of query and queryAll calls to the JAX-WS API fails.

During profile creation, the script is executed if you use the -applyPerfTuningSetting development parameter for the manageprofiles command or if you selected any of the following choices in the Profile Management tool:

  • On the Environment selection page, the IBM BPM Advanced Process, Center stand-alone profile or the IBM BPM Advanced, Process Server stand-alone profile is selected, as in the following illustration:





  • On the Profile Creation Options page, the Advanced profile creation option is selected, as in the following illustration:





  • On the Profile Name and Location page, the Development or the Peak option is selected.

Environment

This information is relevant for the IBM Business Process Manager Advanced Process Center stand-alone profile and the IBM Business Process Manager Advanced Process Server stand-alone profile.

Diagnosing The Problem

On the client side, when this problem exists, execution of query and queryAll JAX-WS calls always returns a NullPointerException indication. The result of this action is custom-client specific, but the query call does not return a list of items.

On the server side, check for an FFDC entry that contains an exception description similar to the following text:

[5/4/11 20:16:30:515 CDT]     FFDC Exception:org.apache.axiom.om.OME xception SourceId:com.ibm.ws.websvcs.transport. http.HTTPTransportSender.invoke ProbeId:388 Reporter:com.ibm.ws.websvcs.transport. http.HTTPTransportSender@310f310f
org.apache.axiom.om.OMExcep tion: java.lang.NullPointerException
    at org.apache.axis2.datasource.jaxb. JAXBDSContext$1.run(JAXBDSContext. java:484)
  &n bsp; at org.apache.axis2.java.security.Ac cessController.doPrivileged(Acces sController.java:76)
&nb sp;   at org.apache.axis2.datasource.jaxb. JAXBDSContext.marshalByElement(JA XBDSContext.java:455)
&n bsp;   at org.apache.axis2.datasource.jaxb. JAXBDSContext.marshal(JAXBDSContext. java:414)

Resolving The Problem

To resolve the problem, complete one of the following actions:

  • Use the WebSphere Application Server Administrative Console to remove the JAXB optimization setting. Follow these steps for each of your defined servers:

    1. Navigate to the Application server page and select the appropriate server:




    2. After opening the Administration servers page for the intended server, select Process definition under Java and Process Management:





    3. On the Process definition page, select Java Virtual Machine under Additional Properties:





    4. On the Java Virtual Machine page, locate the field for Generic JVM arguments:




    5. In the Generic JVM arguments field, delete the -Dcom.ibm.xml.xlxp.jaxb.opti.level=3 setting.

    6. Click OK and Save.

    7. Restart the server.
  • Download and install IBM Business Process Manager Version 7.5.0 Fix Pack 1. The issue is resolved in Fix Pack 1.

[{"Product":{"code":"SSFTN5","label":"IBM Business Process Manager Advanced"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Installation \/ Configuration","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"7.5.1.2;7.5.1.1;7.5.1;7.5.0.1;7.5","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Product Synonym

BPM

Document Information

Modified date:
15 June 2018

UID

swg21500733