IBM Support

I cannot launch FileNet Business Process Manager Process Configuration Console after the successful installation of Process Engine 5.0

Troubleshooting


Problem

I cannot launch FileNet Process Configuration Console (PCC) after the successful installation of FileNet Business Process Manager Process Engine (PE) 5.0.

Symptom

When launching PCC the first time, the user keeps getting a second logon prompt, and keeps getting the Failed to get configuration file WcmApiConfig.properties error message when supplying a user name and password.

Here is the excerpt from the java console output :


    Java Plug-in 1.5.0_12

    Using JRE version 1.5.0_12 Java HotSpot(TM) Client VM

    User home directory = C:\Users\Administrator

    network: Loading user-defined proxy configuration ...

    network: Done.

    network: Loading proxy configuration from Internet Explorer ...

    network: Done.

    network: Loading direct proxy configuration ...

    network: Done.

    network: Proxy Configuration: No proxy

    basic: Cache is enabled

    basic: Location: C:\Users\Administrator\AppData\LocalLow\Sun\Java\Deployment\cache\javapi\v1.0

    basic: Maximum size: unlimited

    ...

    ...

    basic: Registered modality listener

    liveconnect: Invoking JS method: document

    liveconnect: Invoking JS method: URL

    network: Version checking for pe3pt.jar, specified version is 5.0.0.0

    network: Version checking for wcm.jar, specified version is 4.02.450.230

    network: Version checking for peResources.jar, specified version is 4.0.0.620

    ...

    ...

    Failed to get configuration file WcmApiConfig.properties

    at filenet.vw.server.Configuration.<init>(Configuration.java:115)

    at filenet.vw.server.Configuration.GetGLOBALConfiguration(Configuration.java:474)

    at filenet.vw.server.Configuration.GetCEURI(Configuration.java:494)

    at filenet.vw.api.VWSession.formulateURLForBootstrap(VWSession.java:5177)

    at filenet.vw.api.VWSession.logonByDomain(VWSession.java:846)

    at filenet.vw.api.VWSession.logon(VWSession.java:706)

    ...

Cause

The Application Engine (AE) 4.0.2 installer lays down the JRE 1.5.0_12, and this JRE version is supported by PE 4.5.1 applet applications. But this JRE is not supported by the PE 5.0 applet applications.

See the P8 5.0 and P8 4.5.x Hardware and Software Requirements below for your reference.

A. From P8 5.0 Hardware and Software Requriements , page 70
https://www-304.ibm.com/support/docview.wss?uid=swg27013654&aid=7



B. From P8 4.5.x, Hardware and Software Requriements , page 77
https://www-304.ibm.com/support/docview.wss?uid=swg27013654&aid=5

Environment

Windows 2008, PE 5.0.

Resolving The Problem

You can use one of the methods below to resolve the problem :

Method 1:

Uninstall the unsupported JRE 1.5.0_12 on the client machine, and install the supported JRE 1.6.0_14.

Note that if you use this method, each of the clients must carry out the above step manually.

Method 2:

The AE appletParameters.properties file can be updated to allow the updated JRE to be automatically downloaded and installed when the client launches one of the PE applet applications the first time. This way the specified JRE is automatically distributed on demand.



Here are the steps:
  1. Put the JRE 1.6.0_14 in the /download directory of the deployed Workplace.
  2. Update the entry below in the appletParameters.properties under WEB-INF of the deployed Workplace.

jre=/download/jre-1_5_0_12-windows-i586-p.exe <Change this to point to the officially supported JRE that you put in the download directory, which is jre-6u14-windows-i586.exe>

Note that you must restart the AE application server in order to have the above change takes effect. In addition, the customer will need to clear the current JRE from the client machine as the new JRE will not be downloaded if there is a valid JRE presents. Also, the appletParameters.properties is not one of the upgrade-able files so if a patch is laid down, it will be over written so the client will need to have a backup and restore it after each subsequent patch.

[{"Product":{"code":"SSTHRT","label":"IBM Case Foundation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Process Engine","Platform":[{"code":"PF033","label":"Windows"}],"Version":"5.0","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21498924