Troubleshooting
Problem
Customer is integrating TM1 with Controller, via the FAP functionality. User launches "IBM Cognos 8 FAP" from the start menu. The Controller "Financial Analytics Publisher" (FAP) Window appears. User starts a publish. User clicks the 'logs' tab. After a few seconds, an error appears.
Symptom
Object: FAP Service
Severity: CRITICAL
Description: Could not login to TM1, host: SERVERNAME, server name: TM1 SERVER NAME, user name: <username>
If hover the mouse over the error, a new message appears:
- Scenario #1: SystemValueInvalid
- Scenario #2: Array index out of range: 1
Cause
The first error message ("Could not login to TM1") is generic.
- TIP: For more examples of this error, see separate IBM Technote #1664572.
The second error depends on the value of <username>:
- Scenario #1: username = Namespace\Administrator
- See separate IBM Technote #1449693 for full details
- Scenario #2: username = Administrator
- Incorrect syntax used for Data Mart definition
- The correct syntax requires the NameSpace ID to be placed before the username, for example: Namespace\Administrator
Resolving The Problem
Scenario #1:
- See separate IBM Technote #1449693 for full details
Scenario #2:
- Modify the Data Mart definition so that the NameSpace ID is placed before the username, for example: NamespaceID\Administrator
Related Information
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
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Document Information
Modified date:
15 June 2018
UID
swg21449708