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"Standard Error 5 - (0x800A000D): Type mismatch" ... "ORA-12899: value too large for column "schemaname"."XFDLINECOLT"."TEXT" (actual: 100, maximum: 50)" when running Database Optimise

Troubleshooting


Problem

User clicks 'Maintain - Database - Optimise'. User performs a database optimize. After a few minutes, user receives an error message.

Symptom

Screen:

Information


Standard Error
Number: 5
Source: FrangoDirect.AccountD.GenerateSummationStructure#ControllerProxyClient
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Runtime.InteropServices.COMException (0x800A000D): Type mismatch
at FrAccountBT.AccountTClass.GenerateSummationStructure(String sGuid, String sUser, Recordset& rsAccounts, Boolean& bGenForm, Boolean& bErr, Int32& lErr)
at Cognos.Controller.Proxy.CCRWS.AccountT_GenerateSummationStructure(String sGuid, String sUser, DataSet& rsAccounts, Boolean& bGenForm, Boolean& bErr, Int32& lErr)
--- End of inner exception stack trace ---
at Microsoft.VisualBasic.ErrObject.Raise(Int32 Number, Object Source, Object Description, Object HelpFile, Object HelpContext)
at Cognos.Controller.Forms.Common.clsLinkStr.GenSum(DataSet& rsGenSum, Boolean& bErr, Int32& lErr)
at Cognos.Controller.Forms.Form.frmOptimize.IRun_DoRun()
[OK]

Event Viewer (Application Log)


Event Type: Warning
Event Source: VBRuntime
Event Category: None
Event ID: 1
Date: 05/10/2010
Time: 11:14:44
User: N/A
Computer: servername
Description:
The VB Application identified by the event source logged this Application FrFormsBT: Thread ID: 4588 ,Logged: Error occured at 05/10/2010 11:14:44 in FrFormsBT, Error No=-2147217833, Source=FrFormsBT.FormsDefineT.GenerateFormStructures, Description=ORA-12899: value too large for column "schemaname"."XFDLINECOLT"."TEXT" (actual: 100, maximum: 50)
ORA-06512: at line 1, HelpFile= HelpContext=0

Cause

Bug in third party (Oracle) 11G rel2 client software.

Environment

Controller application server has the original (unpatched) version (11.2.0.1.0) of the Oracle 11G release 2 client software installed on it.

Diagnosing The Problem

The screen error message is generic. Instead, you can confirm whether this Technote applies to you by checking the entry inside the Windows Event Viewer's application log.

Resolving The Problem

Patch the Oracle 11Gr2 client on the Controller application server, using Oracle patch #10100100.

  • TIP: This is also known as "11.2.0.1.0 Patch 6 (11.2.0.1.6P) 32-bit"

Steps:

IMPORTANT: If using Windows 2008, then when launching the command prompt (see later) you must do the following:

  • Click "Start - Programs - Accessories"
  • Right-click on "Command Prompt" and choose "Run as administrator".

  1. Download Oracle patch 10100100 (also known as the file "p10100100_112010_WINNT.zip"). TIP: At the time of writing, this was available from here: https://updates.oracle.com/ARULink/PatchDetails/process_form?patch_num=10100100
  2. Obtain a short period of downtime (no users on the Controller system)
  3. Logon to the Controller application server as an administrator
  4. Launch "Controller Configuration" and open the section "Batch Services"
  5. Stop all the batch processes
  6. Launch Windows Explorer, and navigate to the Oracle client BIN folder. TIP: By default, this is: C:\app\Administrator\product\11.2.0\client_1\BIN
  7. Rename the file "oci.dll" to "oci.dll.old"
  8. Extract the file "p10100100_112010_WINNT.zip" into a folder (for example C:\10100100). TIP: Make sure that you now have a folder structure such as: C:\10100100\custom , C:\10100100\etc , C:\10100100\files.
  9. Modify the system variable "ORACLE_HOME" to the location of your Oracle client. TIP: By default, this is: C:\app\Administrator\product\11.2.0\client_1
  10. Launch a command prompt (if using Windows 2008, then see the warning above), and change directory to the patch folder (for example cd C:\10100100 <Enter>)
  11. Type the following command (modify path name as appropriate): C:\app\Administrator\product\11.2.0\client_1\OPatch\Opatch apply <Enter>
  12. There should eventually be a success message similar to the one shown at the end of this IBM Technote (see below)
  13. Launch "Controller Configuration" and open the section "Batch Services"
  14. Start "Controller batch process 1" only
  15. Reboot the application server, and test.

Success message:

    "...Copying file to "C:\app\Administrator\product\11.2.0\client_1\bin\OraOLEDButl11.dll"
    ApplySession adding interim patch '10100100' to inventory

    Verifying the update...
    Inventory check OK: Patch ID 10100100 is registered in Oracle Home inventory with proper meta-data.
    Files check OK: Files from Patch ID 10100100 are present in Oracle Home.
    Execution of 'cmd /C "D:\10100100\custom\scripts\post.bat" -apply 10100100 ':

    Return Code = 0

    The local system has been patched and can be restarted.

    OPatch succeeded"

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21448885