IBM Support

"Access denied" and "Microsoft IE Shell has stopped working" errors when installing/using Controller client on Windows 7

Troubleshooting


Problem

I.T. administrator is trying to install the Controller 8.5.1 client on a client PC running Windows 7. However, they are receiving errors/problems when installing/using the client.

Symptom

Depending on what you are doing (installing pre-requisite third-party components, running pre-requisite scripts/installing Controller client/launching the client) you may get one or more of the following errors:

  • '\\servername\client_share'

  • CMD.EXE was started with the above path as the current directory.
    UNC paths are not supported. Defaulting to Windows directory.
    Microsoft (R) .NET Framework CasPol 2.0.50727.4927
    Copyright (c) Microsoft Corporation. All rights reserved.

    ERROR: Runtime error: Access denied. You might not have administrative credentials to perform this task. Contact your system administrator for assistance.

    For usage information, use 'caspol -?'

  • Microsoft IE Excecute shell

  • Microsoft IE Shell has stopped working
    Windows can check online for a solution to the problem
    * Check online for a solution and close the program
    * Close the program

    Description:
    Stopped working
    Problem signature:
    Problem Event Name: CLR20r3
    Problem Signature 01: ieexec.exe
    Problem Signature 02: 2.0.50727.4927
    Problem Signature 03: 4a275c07
    Problem Signature 04: IEExec
    Problem Signature 05: 2.0.0.0
    Problem Signature 06: 4a275c07
    Problem Signature 07: 9
    Problem Signature 08: 28f
    Problem Signature 09: System.IO.FileNotFoundException
    OS Version: 6.1.7600.2.0.0.256.48
    Locale ID: 2057

Cause

Client device has not been correctly configured with a Microsoft .NET trust.

This has been caused by the changes (since Windows XP) in the security architecture of newer Microsoft operating systems (such as Vista and Windows 7). By default, Microsoft UAC (User Account Control) does not automatically allow certain administrative tasks to be performed, even if the Windows user is a member of the local 'Administrators' group.

More Information:

  • The Microsoft tool "Caspol" is used to add/create .NET trust code groups
  • In Windows 7, this must be run by the user Administrator

NOTE: In other words:
  • In Windows 7, you cannot simply run the command as a Windows user who is a member the Windows user group "Administrators"
  • Instead, it must be the exact user "Administrator".

Environment

Client PC running Windows 7 operating system.

Resolving The Problem

Either:

  1. Disable Microsoft UAC (User Account Control)
  2. Or perform all the installation steps as the user 'Administrator'.

TIP:
  • Method (2) is probably easier for most customers
  • After doing the above, you must remember to check that the file "EXCEL.EXE.CONFIG" has been copied into the same folder as EXCEL.EXE (for example C:\Program Files\Microsoft Office\OFFICE11). This must be done because (by default) Window 7 has both .NET Framework 2 and 3 installed, and the Controller Excel Add-In needs to know which version (of the .NET Framework) to use.

(1) Steps to disable Microsoft UAC (User Account Control):

  • Logon to Windows 7 as a user who is a member of the local "administrators' group
  • Click "Start - Control Panel"
  • Click "User Accounts and Family Safety" - "User Accounts"
  • Click "Change User account control settings"
  • Modify slider, to reset settings to the lowest level ("Never Notify")
  • Click OK
  • Re-run CASPOL .NET trust command line batch file (for example "Controller_NET2.0_caspol_trust.bat")
  • Test.

(2) Steps to perform all the installation steps as the user 'Administrator':

  • Logon to Windows 7 as a user who is a member of the local "administrators' group
  • Locate the caspol from the command line batch file (for example "Controller_NET2.0_caspol_trust.bat")
  • Right-click on the file (for example "Controller_NET2.0_caspol_trust.bat") and choose "Run as Administrator".

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21447553