IBM Support

LDAPSYNC Error: Connection Reset

Troubleshooting


Problem

The LDAPSYNC Cron Task fails while trying to sync users from Active Directory. The Maximo Log shows "Connection reset" errors and no user records are synched.

Symptom

The following error will be displayed in the Maximo Log while the LDAPSYNC Cron Task is running.

User synchronization could not be performed because of error Connection reset. The error count was 992.
javax.naming.CommunicationException: Connection reset [Root exception is java.net.SocketException: Connection reset]; remaining name 'dc=ibm,dc=com'
at com.sun.jndi.ldap.LdapCtx.doSearch(LdapCtx.java:1976)
at com.sun.jndi.ldap.LdapCtx.searchAux(LdapCtx.java:1821)
at com.sun.jndi.ldap.LdapCtx.c_search(LdapCtx.java:1746)

Cause

While attempting to sync records with the Maximo Database a query is executed which may take several seconds to return results. If Maximo does not receive an immediate response from the database, the LDAP connection with the Directory Server may time out.

Environment


Diagnosing The Problem

To collect debug information necessary for identifying this issue, enable the following loggers in Maximo.

a) Sql logging for cron task (DEBUG level)
log4j.logger.maximo.sql.crontask.LDAPSYNC
or
log4j.logger.maximo.sql.crontask.LDAPSYNC.<instancename>


If the Logging application does not support this level of logging, you must insert a row into MaxLogger from the back end and restart the server. For example:

insert into maxlogger (active, internal, logger,
logkey, loglevel, maxloggerid)
values (1, 0, 'VMM Sql',
'log4j.logger.maximo.sql.crontask.LDAPSYNC',
'DEBUG', nextval for maxloggerseq);


b) Other logging for cron task (DEBUG level)
log4j.logger.maximo.crontask.LDAPSYNC

Resolving The Problem

Add the following property to the Maximo System Properties application?

mxe.db.UseSiteListInQuery

Select New Row, add this property and set the value to 1. Check Global Only, Online Changes Allowed and Live Refresh. Then save the record and do a Live Refresh from the Select Action menu.

This property fixes a performance issue found when assigning users to certain Security Groups when All Site Access is not enabled.

[{"Product":{"code":"SSLKT6","label":"IBM Maximo Asset Management"},"Business Unit":{"code":"BU055","label":"Cognitive Applications"},"Component":"Cron Task Setup","Platform":[{"code":"PF025","label":"Platform Independent"}],"Version":"7.1;7.1.1;7.2;7.2.1;7.5","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSWK4A","label":"Maximo Asset Management Essentials"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSLKTY","label":"Maximo Asset Management for IT"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SSKTXT","label":"Tivoli Change and Configuration Management Database"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}},{"Product":{"code":"SS6HJK","label":"Tivoli Service Request Manager"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":" ","Platform":[{"code":"","label":""}],"Version":"","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
13 April 2021

UID

swg21441974