IBM Support

ANR8779E Unable to open drive <tape device name>, error number=5.

Troubleshooting


Problem

A tape is mounted in a drive by a Library Manager. A library Client writes to the tape and closes the tape. Later on, the ANR8779E error is received during dismount by the Library Manager and on retry, the dismount succeeds.

Symptom

In addition to receiving ANR8779E errors, the overall performance of the tape drive is affected.

Cause

Third-party software that scans hardware and interferes with the tape device driver.

Environment

Tivoli Storage Manager servers and storage agents running on Windows using Library Sharing.

Diagnosing The Problem

A trace of the Spectrum Protect server shows that access to the tape drive was denied. For example:

<timestamp> [44][pvrmp.c][7763][]:Background dismount of volume "A12345" started.
<timestamp> [44][pspvr.c][2664][]:PvrOpenDevice: error opening <tape device name>
Reason: Access is denied.
path <tape device name> handle -1 rc 4e
<timestamp> [44][pspvr.c][3510][]:PvrCheckReserve with rc= 79

An IBM device-driver trace captured at the same time shows that an OPEN call to the tape drive was performed by some program other than Tivoli Storage Manager. The device-driver trace might also show TEST UNIT READY and PERSISTENT RESERVE calls. For example:

<timestamp> class.c, 3093: T_class.ClassInterpretSenseInfo SCSIOP: SCSIOP_TEST_UNIT_READY
<timestamp> class.c, 3093: T_class.ClassInterpretSenseInfo SCSIOP: SCSIOP_PERSISTENT_RESERVE_OUT

Resolving The Problem

In this case, the following third-party software programs were interfering with the tape device driver:

  • HP Insight Management WBEM Providers for Windows Server 2003/2008
  • Altiris Hardware Discovery service
  • Altiris Agent (AeXNSAgent.exe)

HP Insight Management WBEM Providers for Windows Server 2003/2008 are not controlled by their
own Windows service. The processes that are invoked by the presence of this software are instances of the WMIPRVSE.EXE image, linked to the Plug and Play service, which cannot be stopped or disabled. The Altiris Agent service can be used for software inventory purposes, and also provides an element
of hardware discovery.

To solve the errors, uninstall the above software programs to prevent them from interfering with the tape device driver.

Also, there may be various HP Insight Management agents, such as :
  • HP Insight Foundation Agents
  • HP Insight NIC Agents
  • HP Insight Server Agents
  • HP Insight Storage Agents

Make sure to use the "Disable Fibre Channel Tape Support" with these agents to also prevent them from interfering with the tape device driver.

There may also be binaries such as hpdiscovery.exe and hpacubin.exe, used to capture hardware
configuration information, that may interfere with the tape device driver. Do not run those binaries to prevent them from interfering with the tape device driver.

Finally, there are the following softwares which are known to interfere with the device driver and cause tape label corruption and cause ANR8355E during dismount :
  • HP Discovery and Dependency Mapping Inventory (DDMI)
  • HP Discovery and Dependency Mapping Advanced Edition (DDMA)

Disable tape drive scans with these software to prevent tape drive conflicts and tape volume label corruption.

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Document Information

Modified date:
17 June 2018

UID

swg21438554