IBM Support

Missing 'wwwroot' folder on webserver causing 'An error occurred while trying to access server' when launching Controller

Troubleshooting


Problem

User launches Controller. User receives error message. All users affected - no users can logon.

Symptom

Screen:
An error occurred while trying to access server

Errors from the Event Viewer:
Crucially, there are no errors logged inside the Event Viewer on either the client or the application server.

Cause

The error 'An error occurred while trying to access server' is generic - there are a huge number of possible causes for this message. See separate IBM Technote #1366724 for more examples.

This IBM Technote specifically relates to the scenario where the problem is caused by a missing folder (wwwroot) in the Microsoft IIS website on the Controller application server. This contains the ASPNET component which receives traffic from the client PC.

Resolving The Problem

Create wwwroot folder, and populate with required ASP.NET files.

Steps:

  1. Logon to Controller application server as an administrator
  2. Open folder C:\Inetpub
  3. Create a subfolder "wwwroot"
  4. Launch a command prompt
  5. Change the folder to c:\WINDOWS\Microsoft.NET\Framework\v2.0.50727
  6. Uninstall ASP.NET by using the following command: aspnet_regiis /u
  7. Re-install ASP.NET by using the following command: aspnet_regiis /i
  8. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4","Edition":"Edition Independent","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21437698