IBM Support

Error: "Class Not Registered" "Null" "Null" when prompted for database server during Security Fusion Module installation

Troubleshooting


Problem

Users may find that they receive a database error while trying to install the Security Fusion Module.

Symptom

The following error is displayed during the installation process when the setup wizard prompts for the DB server:

  • Class Not Registered Null Null

Cause

The Class not registered error is usually seen when you attempt to install the Security Fusion Module and the sqldmo.dll file has not been registered with the system.

Resolving The Problem

  1. Search your hard drive for the sqldmo.dll file.
  2. Make a copy of the file and place the copy in a newly created directory containing only this file.
  3. Hold the Shift key and right click the newly created directory then select Open command window here.
  4. Enter the following command: regsvr32.exe sqldmo.dll

This will register it with the system, which should allow the install to continue successfully.
 

[{"Product":{"code":"SSETBF","label":"IBM Security SiteProtector System"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Security Fusion Module","Platform":[{"code":"PF033","label":"Windows"}],"Version":"3.0;3.1.1","Edition":"","Line of Business":{"code":"LOB24","label":"Security Software"}}]

Historical Number

2470

Document Information

Modified date:
20 January 2021

UID

swg21434840