Flashes (Alerts)
Abstract
The IBM® Tivoli® Storage Manager Version 6.2 server installation wizard fails to obtain all of the database information on Windows® 2003 systems with multiple instances. During a server upgrade from Version 6.1, the installation wizard is not able to redefine and upgrade the databases after the first instance.
Content
Cause:
The installation wizard fails to establish a new Remote Execution and Access (RXA) connection after the first connection is established. The first set of DB2® instance information is processed and saved but any additional server instances are not processed correctly.
Symptoms:
When you start the Tivoli Storage Manager server you get the following messages:
ANR4726I The ICC support module has been loaded.
ANR0990I Server restart-recovery in progress.
ANR0152I Database manager successfully started.
ANR0172I rdbdb.c(1594): Error encountered performing action ActivateDatabase.
ANR0162W Supplemental database diagnostic information: -1031:**No State Information Available (77)**:-1031 (**No Other
Information Available (98)**).
Solution:
For each instance that does not upgrade correctly, reconfigure your database. Check the Instance.dat file in the Tivoli Storage Manager server installation directory for a list of your server instances.
Complete the following steps for each server instance that did not upgrade:
1. Set the database instance:
set DB2INSTANCE=instance_name
2. Enter this command on one line.
db2set -i instance_name
"DB2_VENDOR_INI=installation_directory\tsmdbmgr.env"
3. Catalog and upgrade the database:
db2start db2 catalog db DatabaseName
db2 upgrade db DatabaseName
4. Stop DB2:
db2stop
This problem is address by APAR IC67436 and will be availabile in Tivoli Storage Manger Server version 6.2.1. Please see the APAR details for additional information http://www-01.ibm.com/support/docview.wss?uid=swg1IC67436
Was this topic helpful?
Document Information
Modified date:
25 September 2022
UID
swg21425361