IBM Support

The IBM® FileNet® P8 Process Engine (PE) 4.0.3-002 fix pack setup fails with Errors occurred during the installation message.

Troubleshooting


Problem

A customer tries to apply the IBM® FileNet® P8 Process Engine 4.0.3-002 fix pack. The Process Engine 4.0.3-002 setup keeps failing at around 99% during the fix pack run.

Symptom

Here is the screen shot of the failure :



Here is the excerpt of the error reported in the PE403-002_setup.log :

    (Mar 1, 2010 4:52:27 PM), Install, com.installshield.product.service.product.PureJavaProductServiceImpl, dbg.install, JVM memory before installing Exec Action (beanKillfnsw-DAy): free=289011664 total=314245120
    (Mar 1, 2010 4:52:27 PM), Install, com.installshield.product.service.product.PureJavaProductServiceImpl, msg1, installing Exec Action (beanKillfnsw-DAy)
    (Mar 1, 2010 4:52:27 PM), Install, com.installshield.product.actions.ExecAction, err, An error occurred and product update failed. Look at the log file /fnsw/tmp_installer/PE403-002_setup.log for details.
    (Mar 1, 2010 4:52:27 PM), Install, com.installshield.product.actions.ExecAction, err, ProductException: (error code = 200; message="Java error"; exception = [ServiceException: (error code = 200; severity = 0; exception = [java.lang.NullPointerException])])
    STACK_TRACE: 13
    ProductException: (error code = 200; message="Java error"; exception = [ServiceException: (error code = 200; severity = 0; exception = [java.lang.NullPointerException])])
    at com.installshield.product.actions.ExecAction.executeProcess(Unknown Source)
    at com.installshield.product.actions.ExecAction.install(Unknown Source)
    at com.installshield.product.service.product.PureJavaProductServiceImpl.installProductAction(PureJavaProductServiceImpl.java:2969)
    at com.installshield.product.service.product.PureJavaProductServiceImpl$InstallProduct.getResultForReplaceProductAction(PureJavaProductServiceImpl.java:8307)
    at com.installshield.product.service.product.InstallableObjectVisitor.replaceComponent(Unknown Source)
    at com.installshield.product.service.product.InstallableObjectVisitor.visitInstallableComponents(Unknown Source)
    at com.installshield.product.service.product.InstallableObjectVisitor.visitProductBeans(Unknown Source)
    at com.installshield.product.service.product.PureJavaProductServiceImpl$InstallProduct.install(PureJavaProductServiceImpl.java:7198)
    at com.installshield.product.service.product.PureJavaProductServiceImpl$Installer.execute(PureJavaProductServiceImpl.java:5359)
    at com.installshield.wizard.service.AsynchronousOperation.run(Unknown Source)
    at java.lang.Thread.run(Thread.java:595)

Cause


The PE 4.0.3-002 fix pack upgrades the FileNet® Image Services (IS) from 4.1.1.56 to 4.1.1.95. One of the first steps is to run killfnsw. The installer could not run killfnsw because the permission on the killfnsw file is not correct. As a result, the installer is not able to un-pack the /fnsw/tmp_installer/IMSInst directory that runs the IS mini-installer for the IS packages.

Resolving The Problem

  1. From the UNIX prompt, run fn_setup -d /.
  2. Verify the permission on /fnsw/bin/killfnsw file by running ls -la killfnsw.
  3. If the owner of the file is not root, run chown root:fnusr killfnsw as root.
  4. The permission should be as follows :
    prompt> ls -la killfnsw
    -rwsr-s--- 1 root fnusr 84788 Jul 26 2007 killfnsw

[{"Product":{"code":"SSTHRT","label":"IBM Case Foundation"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Business Process Manager","Platform":[{"code":"PF027","label":"Solaris"}],"Version":"4.0.3","Edition":"All Editions","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21423122