IBM Support

'Service "sapgw00" unknown' error in JCo trace of WebSphere Adapter for SAP Software

Troubleshooting


Problem

The error "service 'sapgw00' unknown" is a common problem on UNIX and Windows systems. The WebSphere Adapter for SAP Software cannot connect to the SAP system due to a missing "sapgw" configuration.

Symptom

On UNIX and Windows systems, adapter fails with error message "service unknown" in JCo traces.

Cause

Service is not being known by the host system where the adapter resides.

Environment

Problem appeared on different operating systems, across different WebSphere runtimes and WebSphere Adapter for SAP Software versions.

Resolving The Problem

The JCo traces of the WebSphere Adapter for SAP Software show the following error message:
"
ERROR service 'sapgw00' unknown
...
Return code: RFC_FAILURE(1)
error group: 102
key: RFC_ERROR_COMMUNICATION

main [15:54:23:311]: [JCoApi] JCoServer open connection failed:
JCO_ERROR_SERVER_STARTUP: Server startup failed at Mon Nov 23 15:54:23
GMT 2009.
This is caused by either a) erroneous server settings, b) the backend
system has been shutdown, c) network problems.
Could not start server: Connect to SAP gateway failed

"

The adapter cannot connect to the SAP system, because the gateway setting is unknown to the adapter. To overcome the problem, add the following entry to your "etc/services" file on your operating system where the adapter resides.


"sapgw00 3300/tcp"

Whereas "sapgw00" is the default, change the port accordingly when using another gateway. For example, "sapgw04" represents SAP system number 04 and the corresponding port should be 3304. Consult your system administrator for any potential port conflicts.

On Windows systems, add a blank line directly after the last entry in the services file. Windows will ignore the last entry otherwise.

If none of above options helped to overcome the problem, verify your load balancing configuration. Ensure that the message server is being set together with the gateway server which is always the application server host. On the SAP system, check your message server configuration via transaction RZ70, "_SLD_MSGSRV".

Also review SAP Notes #896973, #540379, #882741 for further checks on your configuration.

If the problem persists, please contact IBM Support.

[{"Product":{"code":"SSMKUK","label":"WebSphere Adapters Family"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Adapter for SAP","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF033","label":"Windows"}],"Version":"7.0","Edition":"","Line of Business":{"code":"","label":""}}]

Document Information

Modified date:
23 June 2018

UID

swg21413812