IBM Support

** Troubleshooting ** Running Excel link report gives error “Debug Assertion Failed!”

Troubleshooting


Problem

User presses F9 to run an Excel link report. User receives an error message.

Symptom

Generic error message (for all Scenarios):


    Microsoft Visual C++ Debug Library
    Debug Assertion Failed!

    Program C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE
    <...>

Scenario #1:

    Specific Error message:

    Microsoft Visual C++ Debug Library
    Debug Assertion Failed!

    Program C: C:\Program Files\Microsoft Office\OFFICE11\EXCEL.EXE
    File: isctype.c
    Line: 56
    Expression: (unsigned)(c+1)<=256
    […]
    Press Retry to debug the application

    After clicking 'Retry':
    Microsoft Office Excel has encountered a problem and needs to close. We are sorry for the inconvenience.

    Afterwards, the following error may also appear:
    IBM Cognos 8 Controller Link
    Assigning function key ({F9}) to
    xll command ((null)) using xlcOnKey failed.
    Excel error no: 2

Cause

The error "Debug Assertion Failed!" is generic. Therefore, there are several potential causes for the similar error messages:

  • Scenario #1 - Invalid (non-alphanumeric) characters used as company codes (or account codes) in the database (and/or in the data to be transferred)
    • This IBM Technote specifically relates to this scenario
  • Scenario #2 - Invalid controller formula used in insert columns
    • See separate IBM Technote #1367464 for more information.
  • Scenario #3 - the report(s) have become invalid/corrupt.
    • See separate IBM Technote #1414483 for more information.
  • Scenario #4 - Russian characters are used in the sheet name
    • See separate IBM Technote #1433459 for more information.
  • Scenario #5 - invalid setting(s) inside the end user's ccr.config configuration file
    • See separate IBM Technote #1347864 for more information

This Technote specifically deals with Scenario #1. In this scenario, the user is attempting to transfer data from an Excel sheet into Controller by using fExpVal in Excel.

The problem is caused by invalid (non-alphanumeric) characters used in the database (and/or in the data to be transferred) as company codes (or account codes).

Controller only supports the following characters (as valid) for account codes:
  • a-z
  • A-Z
  • 0-9
  • '-' (dash)
  • and '_' (underscore)

Examples for invalid characters (among others) are:
  • ä, ö, ü, å, é, è, à

Environment

It was possible to use the above 'invalid' characters in Consolidator, so this error is most likely to appear in a system that has been previously migrated from Consolidator to Controller.

Resolving The Problem

Fix:

  • Replace invalid characters in codes by using the respective functionality (for example "Change Table").
  • Afterwards, modify the Excel spreadsheet to reference these updated codes.

Steps:
  1. Use the menu items "Maintain / Company Structure / Change Table - Define/Run"
  2. Check the "Company codes" for invalid characters. TIP: In Change Tables, there is a validation for characters, so you can not enter any invalid characters for new codes.
  3. Afterwards, in each Excel sheet, locate any cells being referenced to the 'bad' accounts (or companies) in the Excel-link formula
  4. Remove any invalid characters found. In other words, change the modified account/company codes to the new values
  5. Test.

Workaround:

Press the 'Ignore' button until the error no longer occurs to avoid being thrown out of Excel.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
15 June 2018

UID

swg21396223