IBM Support

InactiveProcessException occurs when playback a schedule

Troubleshooting


Problem

This technote provides information on InactiveProcessException error, that can occur during playback of a schedule in IBM Rational Performance Tester.

Symptom

During playback of a schedule with Rational Performance Tester controller, the below error is thrown


    !MESSAGE RPTI0009W Test run aborted due to error.
    com.ibm.rational.test.lt.execution.rac.TestLaunchException: org.eclipse.hyades.internal.execution.local.control
    .InactiveProcessException


Restarting the workstation does not help this error.

Cause

The InactiveProcessException means that the separate process when running the test was either unable to start or died very soon after starting. It could be caused by inappropriate heap size. This was identified as product defect under APAR PK96264.

Resolving The Problem

This issue was resolve in Rational Performance Tester 8.1.0.3 and above.

If you can not upgrade immediately, one possible workaround is:

  1. Add new localhost location. Attributes should be hostname=localhost, name=localhost, deployment directory=c:\test (or another directory).
  2. Under General Properties for the localhost location add a new name/value pair of RPT_VMARGS with value -Xmx1024m(this value should be adjusted based on Rational Performance Tester controller's available memory).
  3. Playback the schedule on the localhost location. Note: Refer to Rational Performance Tester's Help for how to create localhost location and add new property RPT_VMARGS.

[{"Product":{"code":"SSMMM5","label":"IBM Rational Performance Tester"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Test Schedules","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.0;8.0.0.1;8.0.0.2;8.0.0.3;8.1;8.1.0.1;8.1.0.2","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21395486