IBM Support

A java.lang.NullPointerException occurs in the wbifailedeventmanager.boeditor and a CWRCV0053E message is seen for WebSphere Process Server (WPS)

Troubleshooting


Problem

When you click Edit Business Data for a failed event in the failed event manager an Error reading XML error is written to the administrative console. You also receive a java.lang.NullPointerException in wbifailedeventmanager.boeditor and the CWRCV0053E error message.

Symptom

The following exception is logged in the SystemOut.log file:

WBIBusinessOb E com.ibm.ws.console.wbi.wbifailedeventmanager.boeditor.
WBIBusinessObjectEditor reloadAction The server returned:
Error reading XML.

WBIBusinessOb E com.ibm.ws.console.wbi.wbifailedeventmanager.boeditor.
WBIBusinessObjectEditor loadPath An unknown error occurred. The server returned: {0}.
java.lang.NullPointerException
at com.ibm.ws.console.wbi.wbifailedeventmanager.boeditor.
WBIBusinessObjectEditor.loadFormForPath(WBIBusinessObjectEditor.java:267)
at com.ibm.ws.console.wbi.wbifailedeventmanager.boeditor.
WBIBusinessObjectEditor.innerloadPath(WBIBusinessObjectEditor.java:251)
at com.ibm.ws.console.wbi.wbifailedeventmanager.boeditor.
WBIBusinessObjectEditor.loadPath(WBIBusinessObjectEditor.java:123)
at com.ibm.ws.console.wbi.wbifailedeventmanager.WBIFailedEventManagerDetail
Action.editData(WBIFailedEventManagerDetailAction.java:198)
at com.ibm.ws.console.wbi.wbifailedeventmanager.WBIFailedEventManagerDetail
Action.execute(WBIFailedEventManagerDetailAction.java:96)
at org.apache.struts.action.RequestProcessor.processActionPerform
(RequestProcessor.java:484)
at org.apache.struts.action.RequestProcessor.process
(RequestProcessor.java:274)

Recovery      E com.ibm.wbiserver.manualrecovery.FailedEventWithParametersImpl restoreParameters() CWRCV0053E: The business data cannot be displayed correctly for failed events with the message ID
"F20C939F78270646_5000065"

Cause

This scenario is working as designed. It is not a problem. Refer to the "Resolving the problem" section for information.

Resolving The Problem

The failed event manager reports the java.lang.NullPointerException in wbifailedeventmanager.boeditor error under the following circumstances:

  • The Service Component Architecture (SCA) application that generated the failed event stops before the failed event manager populates the business data to the failed event manager database.

    In this scenario, the SCA application generates a failed event. The failed event is stored in the failed event manager database. The artifact loader queries the application XML Schema Definition (XSD) to populate the business data. However, because the application has already stopped, the operation fails. The artifact loader logs the following warning:

    ArtifactLoade W
    com.ibm.ws.ral.RALServer getArtifactsInfo Can not get ArtifactLoader  instance of app: <application name> please check whether the app   existing and started


    In the failed event manager, when you click Edit Business Data, it results in the Error reading XML error.

    To resolve the problem, start the SCA application. The artifact loader queries the schema and populates the business data in the failed event manager. Additionally, the artifact loader caches the schema information in the WebSphere Process Server runtime memory, which populates the business data even when the application is stopped.


  • Notes:
    • For every failed event, the artifact loader queries the schema at least once so that the business data is cached.
    • The cache is cleared when WebSphere Process Server is restarted.

  • WebSphere Process Server is restarted and auto-start is disabled for the SCA application.

    In this scenario, the SCA application is not set to start automatically when WebSphere Process Server starts. As in the first scenario, the artifact loader cache is cleared when the server is recycled. If you click Edit Business Data, the failed event manager reports the Error reading XML error even for a failed event for which the business data was visible before the server was recycled. To resolve the problem, start the SCA application.

This behavior is known behavior for the failed event manager application.

[{"Product":{"code":"SSQH9M","label":"WebSphere Process Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Failed Management Console","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"6.2;6.1.2;6.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21388352