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Collecting data for IBM FileNet Business Process Framework problems (All Versions)

Question & Answer


Question

Collecting data for problems with IBM® FileNet® Business Process Framework. Collecting this MustGather information before calling IBM Support will help you understand the problem, save time analyzing the data, and reduce the time required to resolve the issue.

Cause

MustGather information can facilitate problem determination and can reduce the time that is needed to resolve Problem Management Records (PMRs). If a code fix is needed, accurate and timely data can speed the development of a code fix.


Collecting MustGather data early, before opening the PMR, helps IBM Support quickly determine if:

  • The symptoms match any known problems
  • The problem is not a defect and can be identified and resolved quickly
  • There is an existing workaround that can reduce the severity of the problem
  • A code fix can be developed to resolve the problem

Answer

There are several types of information that you should gather before you contact IBM Support:

  • Product version information
  • Server deployment information
  • SSO information
  • Fixes, add-ons, custom code
  • Operating system information
  • Detailed problem information
  • Log files

If you need to enable DEBUG logging for Business Process Framework, see the following sections at the end of the document:
  • Capturing DEBUG-level log information for Web application problems
  • Capturing DEBUG-level log information for BPF_Operations problems


Collecting product version information
You must collect information about the specific version of Business Process Framework that you are using.

To determine which version of Business Process Framework you are using:
  1. Collect the Web application Information:
    1. From a Microsoft Internet Explorer browser session on one of the client machines, enter the URL

      http://<BPF_server>:<port_number>/bpf/About.jsp

      where

      <BPF_server> is the machine hosting the BPF web application

      <port_number> is the port on which the BPF web application server is running.

    2. Save the information by taking a screen capture.
  2. Collect the version information file, Bp8Version.txt, from the application server. The file is located in the directory where Business Process Framework is deployed.
  3. Collect the resource bundle, bpfCMResources.jar, from the application server. The file is located in the WEB-INF\lib subdirectory of the directory where Business Process Framework is deployed.


Collecting server deployment information, including the following
  1. Collect current AE, CE and PE release/and fixpack levels.
  2. Collect application server type (e.g. WebSphere) and release/patch level.
  3. Collect hardware platform and operating system release/patch level (see below for details).
  4. Collect LDAP server type and release/patch level.
  5. Determine whether or not BPF is being used in a clustered/farmed environment.
  6. Collect information on any firewalls, load balancers, and/or proxies in use.
  7. Determine whether or not AE, CE, PE, and/or BPF are collocated.
  8. Determine whether or not AE, CE, PE, and/or BPF are installed on a virtualized platform (e.g. VMWare).


Collecting SSO information
  1. Is SSO installed and in use for BPF and/or AE?
  2. If so, what SSO technology is being used (e.g. SiteMinder)?


Collecting information about fixes, add-ons, and custom code
  1. Catalog any and all IBM FileNet testfixes present, not just those specifically for BPF.
  2. Note any and all IBM FileNet P8 add-on products (e.g. Records Manager, eForms, etc.) present - along with their release/patch levels.
  3. Catalog and collect information on custom code or products from business partners.
  4. Catalog and collect information on custom code from IBM Lab Services.
  5. Catalog and collect information on custom code from IBM FileNet Development teams.
  6. Catalog and collect information on custom code developed in-house by the customer.



Collecting operating system information
Gather the following information about your environment for the affected servers or client workstations:
  • The operating system version.
  • The operating system environment variables.
  • The operating system kernel parameters.

To collect the required information about your operating system, run the following commands that are listed for your operating system.

    AIX users
    Enter the following commands and save the information that is returned by each command.

    CommandInformation returned
    uname -a or oslevel -qOS Version
    /usr/sbin/instfix -ivqOS Patches or Maintenance level
    envOS Environment Variable
    errptOS Configuration & Error Reporting
    /usr/sbin/lsattr -E -l sys0OS Kernel parameters


    HP-UX users
    Enter the following commands and save the information that is returned by each command.

    CommandInformation returned
    uname -aOS Version
    /usr/sbin/swlist -l productOS Patches or Maintenance level
    envOS Environment Variable
    /usr/sbin/dmesgOS Configuration & Error Reporting
    /usr/sbin/sysdefOS Kernel parameters


    Solaris users
    Enter the following commands and save the information that is returned by each command.

    CommandInformation returned
    uname -aOS Version
    /usr/bin/showrev -aOS Patches or Maintenance level
    envOS Environment Variable
    /usr/sbin/prtdiag -vOS Configuration & Error Reporting
    /usr/sbin/sysdef -D
    /usr/bin/getconf -a
    OS Kernel parameters


    Windows users
    Enter the following commands and save the information that is returned by each command.

    CommandInformation returned
    winmsd.exe  



    OS Version, Patches and Maintenance level

    Tip: In winmsd.exe, select File > Export to save the generated information to a text file (e.g. winmsd.txt).
    setOS Environment Variable
    cscript C:\windows\system32\eventquery.vbs /L application /R 1000 /V

    cscript C:\windows\system32\eventquery.vbs /L system /R 1000 /V

    cscript C:\windows\system32\eventquery.vbs /L security /R 1000 /V
    OS Event Log Error Reporting


Collecting information about the problem
Gather the following information about the specific problem that you are encountering with IBM FileNet Business Process Framework:
  • How often does the problem occur?
  • Can the problem be reproduced?

  • If the problem can be reproduced, write clear, detailed steps to reproduce the problem.
  • How many users are affected by the problem?
  • What is the business impact of the problem?
  • Is there a workaround for the problem?


In addition to answering these questions, you should take screen shots of the problem, if possible.


Collecting log files
Depending on the type of problem that you are encountering, you should also gather log files to send to IBM Support.

    All problems
    No matter what problem you are experiencing, you should collect the system log files. Collect the appropriate log file for your environment.

    Operating systemFiles to collect
    AIX/var/adm/syslog/syslog.log
    HP-US/var/adm/syslog/syslog.log
    Solaris/var/adm/messages
    /var/log/syslog
    Linux/var/log/syslog
    WindowsWindows Application Event Log
    Windows System Event Log

    Tip: To save Windows event logs, go to Control Panel > Administrative Tools > Event Viewer and save each file as type .evt. The saved files can then be transferred and opened on another machine.


    Business Process Framework Web application problems
    If you are experiencing problems with the Business Process Framework Web application, collect the DEBUG-level bp8.log file and the external.log file from the WEB-INF\logs subdirectory of the directory where Business Process Framework is deployed.

    If the HTTP access logs are available on the application server, gather those log files too.


    Business Process Framework Operations (BPF_Operations) problems
    If you are experiencing problems with BPF_Operations, collect the DEBUG-level bp8operations.log file and the adaptor.log file. By default, the files are located in the system directory. For example, the system directory is System32 on Windows.

    If the bp8operations.log file and the adaptor.log file are not in the system directory, they are in the directories that are defined in the BPF_Operations log4j.xml file. The BPF_Operations log4j.xml file is in the bp8ciops.jar file. The location of the bp8ciops.jar file is defined in the Required Libraries class path in the Business Process Manager Process Engine Component Manager.


    Business Process Framework Explorer problems
    If you are experiencing problems with the Business Process Framework Explorer, collect the Windows Application event log.


Next steps
Once you collect the required information, you can analyze the data or submit the information to IBM Support.


Capturing DEBUG-level log information
If your IBM Software Support representative asks you to enable DEBUG-level logging, you can enable the logging for the component of Business Process Framework with which you are experiencing problems.

    Capturing DEBUG-level log information for Web application problems
    To capture DEBUG-level log information in the bp8.log file and the external.log file for Web application problems:
    1. Stop the application server and remove the existing bp8.log file and the existing external.log file. You can remove the log files by deleting them or by renaming them. Both files are located in the WEB-INF\logs subdirectory of the directory where Business Process Framework is deployed.
    2. Open the log4j.xml file, which is located in the WEB-INF subdirectory of the directory where Business Process Framework is deployed.
    3. Change the value of the level value parameter to “debug” and the value of the additivity parameter to “true” in the following lines of the log4j.xml file:

      <logger name="com.filenet.bp8" additivity="true">
      <level value="
      debug"/>
      <appender-ref ref="bp8"/>
      </logger>

      <logger name="com.filenet.wcm.api" additivity="
      true">
      <level value="
      debug"/>
      <appender-ref ref="external"/>
      </logger>

      <root>
      <level value="
      debug"/>
      <appender-ref ref="external"/>
      </root>

    4. Restart the application server.
    5. Reproduce the problem and gather the bp8.log file and the external.log file.
    6. Reset the logging levels for the bp8.log file and the external.log file to “error”:
      1. Stop the application server.
      2. Change the instances of “debug” that you changed in step 3 to “error”.
      3. Restart the application server.
    Capturing DEBUG-level log information for BPF_Operations problems
    To capture DEBUG-level log information in the bp8operations.log file and the adaptor.log file for BPF_Operations problems:
    1. Extract the BPF_Operations log4j.xml file from the bp8ciops.jar file. The location of the bp8ciops.jar file is defined in the Required Libraries class path in the Business Process Manager Process Engine Component Manager.
    2. Add the (%M:%L) to the ConversionPattern parameters where indicated, add additivity="false" to the logger nodes where indicated, and change the value of the level value parameter to debug in the following lines of the log4j.xml file:
    <appender name="R" class="org.apache.log4j.DailyRollingFileAppender">
    <param name="File" value="adaptor.log"/>
    <param name="DatePattern" value="yyyy-MM-dd"/>
    <layout class="org.apache.log4j.PatternLayout">
    <param name="ConversionPattern" value="%d %-5p %C{2} (%M:%L) - %m\n"/>
    </layout>
    </appender>

    <appender name="Bp8Operations" class="org.apache.log4j.DailyRollingFileAppender">
    <param name="File" value="bp8operations.log"/>
    <param name="DatePattern" value="yyyy-MM-dd"/>
    <layout class="org.apache.log4j.PatternLayout">
    <param name="ConversionPattern" value="%d %-5p %C{2} (%M:%L) - %m\n"/>
    </layout>
    </appender>

    <logger name="com.filenet.wcm.api" additivity="false">
    <level value="debug"/>
    <appender-ref ref="R"/>
    </logger>

    <logger name="com.filenet.operations.Bp8Operations" additivity="false">
    <level value ="debug"/>
    <appender-ref ref="Bp8Operations"/>
    </logger>

    <logger name="oracle.jdbc.pool.OracleDataSource" additivity="false">
    <level value ="debug"/>
    <appender-ref ref="Bp8Operations"/>
    </logger>

    <logger name="net.sourceforge.jtds.jdbcx" additivity="false">
    <level value ="debug"/>
    <appender-ref ref="Bp8Operations"/>
    </logger>

    <logger name="com.ibm.db2.jcc.DB2DataSource" additivity="false">
    <level value ="debug"/>
    <appender-ref ref="Bp8Operations"/>
    </logger>

    <root>
    <level value ="debug"/>
    <appender-ref ref="R"/>
    </root>
    1. Stop the Component Manager.
    2. Save your changes and replace the version of the BPF_Operations log4j.xml file that is in the bp8ciops.jar file with the version that you updated.
    3. Restart the Component Manager.
    4. Reproduce the problem and gather the bp8operations.log file and the adaptor.log file.
    5. Reset the logging levels in the BPF_Operations log4j.xml file to “error”:
      1. Extract the BPF_Operations log4j.xml file from the bp8ciops.jar file.
      2. Change the instances of “debug” that you changed in step 2 to “error”.
      3. Stop the Component Manager.
      4. Save your changes and replace the version of the BPF_Operations log4j.xml file that is in the bp8ciops.jar file with the version that you updated.
      5. Restart the Component Manager.

[{"Product":{"code":"SSNVLC","label":"FileNet Business Process Framework"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Not Applicable","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF016","label":"Linux"}],"Version":"4.1;3.6","Edition":"Edition Independent","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
17 June 2018

UID

swg21383850