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Applying latest Fix Pack may yield error: zip com.ibm.rational.team.write.runonce.key 1.0.0.v200810242053 not found

Troubleshooting


Problem

This technote explains how to resolve an error, []zip com.ibm.rational.team.write.runonce.key 1.0.0.v200810242053 not found[], that can occur when attempting to install an IBM Rational product Fix Pack using the Installation Manager.

Symptom


Either of the following scenarios will produce this error:

  1. When updating ClearCase or ClearQuest from 7.1.0.0 to fix pack 7.1.0.1, the installation aborts and reports an error:

    "Failed to find all installation files
     zip com.ibm.rational.team.write.runonce.key 1.0.0.v200810242053 not found"
  2. When you are attempting to apply the current fix pack for any Rational Product through Installation Manager where there is one or more than one product installed on the same system you may receive an error:

    zip com.ibm.rational.team.write.runonce.key 1.0.0.v200810242053 not found 

Cause



The cause of this error is a result of an attempt to apply a fix pack without referencing the original installation repository. This cause holds true to any Rational Product that is installed on the same system.


For example:

In symptom 1 above Fix pack 7.1.0.1 is a "delta" update which requires version 7.1.

This issue is caused by not having the version 7.1 repository available as a selected repository.
The 7.1 repository and the 7.1.0.1 repositories need to be accessible for the Installation Manager to apply the updates.


In the case where you are applying the fix pack to both ClearCase and ClearQuest four repositories are needed:
  • ClearCase version 7.1
  • ClearQuest version 7.1
  • ClearCase fix pack 7.1.0.1
  • ClearQuest fix pack 7.1.0.1

Resolving The Problem

To resolve the issue you must ensure that all repositories are present and active at the point you want to apply a fix pack.

Add the required repositories to the Installation Manager in "File" -> "Preferences" and rerun the installation.

For instance, if you have ClearCase, ClearQuest and RequisitePro installed on the same system and want to apply the fix packs, you must apply all the fix packs at the same time. You cannot apply only one fix pack to one product.

Here are the basic steps to correct the issue:

  1. Launch IBM Installation Manager
  2. Go to File, then Preferences
  3. Under the Repositories section ensure that you have a check mark active for the original installation repository as well as the Fix Pack repository.

    Once all areas have been made active you can proceed with the update and apply the fix pack.

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Document Information

Modified date:
16 June 2018

UID

swg21381944