Troubleshooting
Problem
Users have been successfully using Controller for some time. Suddenly, all Controller sessions are simultaneously disconected. It may be that no further connections to Controller are possible until the application server is rebooted.
Symptom
Event Viewer - Application Log on Controller Application server
#1
- ISAPI 'c:\windows\microsoft.net\framework\v2.0.50727\aspnet_isapi.dll' Reported itself as unhealthy for the following reason: 'Deadlock detected'.
#2
- A process serving application 'DefaultAppPool' exceeded time limits during shut down. The process id was '796'
Cause
There are several potential causes for error #1.
- For more examples, see separate IBM Technote #1567561.
This IBM Technote specifically relates to the scenario where the Controller web server's Microsoft IIS website believes that it is overloaded (or under attack) and has therefore shut down part of its functionality.
There are several potential reasons for this behaviour:
- Scenario #1 - Incorrect settings for the performance property 'Limit the kernel request queue (number of requests)' for the Application Pool (for example 'DefaultAppPool') in Internet Information Services (IIS) Manager
- For more details, see Third Party (non-IBM) website links at the end of this Technote
- Scenario #2 - Overloaded server hardware
Resolving The Problem
Scenario #1
Modify the value/setting for 'Limit the kernel request queue (number of requests)' either:
- to a higher value (for example 4000)
- or set it to infinite (by disabling the limit).
TIP: See attached document "KB 1224419 - Printscreen of 'Limit the kernel request queue (number of requests)'.doc" for a printscreen.
Steps:
- Obtain a short period of downtime
- Logon to the Controller application server as an administrator
- Open 'Administrative Tools' and select 'Internet Information Services (IIS)'
- Locate the website's virtual directory 'Cognos8\controllerserver'
- Right-click on 'controllerserver' and choose 'properties'
- Make a note of the value of the 'Application pool' (TIP: By default, this is 'DefaultAppPool')
- Close this properties page
- Expand 'Internet Information Services - Application Pools', and locate the application pool name (default name = 'DefaultAppPool')
- Right-click on the pool (e.g. DefaultAppPool) and choose 'properties'
- Click 'Performance' Tab
- Change the 'Request queue limit' setting as desired (for example, increase the value to '4000' - if this fails, try unticking the box 'Limit the...' to make the value infinite)
- Reboot application server, to ensure that setting change has 100% taken place
Scenario #2
- Ensure that your server hardware is in line with Proven Practice guidance
- For example, see Proven Practice document 'Controller 8.4 Architecture and Server Sizing'
- Upgrade the Controller application server's hardware if necessary.
- Ensure that only one complex Controller process is running simultaneously, by ensuring that the batch queue is not disabled
- In other words, check that there is NOT a server preference called 'batchmode off' inside each database - see separate IBM Technote #1347433 for full details
- Ensure that there is only one batch service set to 'running'
- See separate Technote #1347433 for full details
Related Information
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1;8.5;8.4;8.3","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Historical Number
1035508
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Document Information
Modified date:
15 June 2018
UID
swg21371195