IBM Support

ADSI Error 8009030C when testing Active Directory Connection

Troubleshooting


Problem

When trying to authenticate / test against an Active Directory Server the following errors will show:

Symptom

Active Directory
1. [ ERROR ] CAM-AAA-0146 The namespace 'XXX' is not available.
CAM-AAA-0064 The function 'CAM_AAA_Configure2' failed.
CAM-AAA-0089 The provider is not initialized.
CAM-AAA-0036 Unable to authenticate because the credentials are invalid.
ADSI Error:
8009030C:
LdapErr: DSID-0C09043E,
comment: AcceptSecurityContext error,
data 0,
vece
System Error:
Logon failure: unknown user name or bad password.

Cause

There are several potential causes for the same/similar errors.

  • TIP: See separate Technote #1588179 for more examples.

This Technote specifically relates to the scenario where Cognos Configuration is configured to use anonymous credentials (i.e. the "Bind Credentials" had been left blank in Cognos Configuration for this namespace) but the Active Directory (AD) domain controller server is configured to not allow anonymous binding.

Environment

The administrator has already checked other typical possible causes, for example:

  • The host and port of the ADS are correct.
  • It is not a cross forest scenario (Cognos Server and Domain Controller are in the SAME forest)
  • The defined ADS is the Domain Controller

Resolving The Problem

Add a valid domain account for the "Bind Credentials" of the namespace definition in Cognos Configuration.

[{"Product":{"code":"SSEP7J","label":"Cognos Business Intelligence"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Install and Config","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.2;10.2.1;10.2.1.1;10.2.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Document Information

Modified date:
26 November 2019

UID

swg21370811