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** Troubleshooting ** Error 'FetchValuesBulk# - File not found Server: Share: User: Psw: Transfer...' when running report

Troubleshooting


Problem

User has configured a spreadsheet/report to use Enhanced Reporting Optimisation ("ERO"). In other words, they have inserted the 'Name' "Optimise2" into cell A1 spreadsheet. Afterwards, user runs the report (e.g. via F9). However, user receives an error.

Symptom

Depending on the environment/version of Controller, the error may look slightly different. However, it will be similar to:


Older versions of Controller:


Controller 10.2.1:

Server was unable to process request. ---> System.ArgumentException: Value cannot be null.
Parameter name: path Server: Share: User: Psw: **** Transfer:0 Prefix...

Cause

Spreadsheet has Optimise2 (also known as 'ERO') enabled, but the Controller application server (and database server share) are not properly configured to use ERO/Optimise2 (for this database connection).

There are several possible scenarios for this misconfiguration:

  • Scenario #1 - (most likely) I.T. Administrator has forgotten to fill the section inside 'Enhanced Reporting Optimisations' inside Controller Configuration
    • In other words, they have forgotten to fill in the section for the database connection that the user is using. IMPORTANT: This has to be filled in for each and every one of the database connections!
  • In other words, the application server does not have ERO properly configured for this database connection.
    • Typically this is because this user is using a recently-created new database connection, where the step to configure ERO inside Cognos Controller Configuration has been forgotten.
  • Scenario #2 - Incorrect values may have been placed inside the Enhanced Reporting Optimisation section.
    • For example, the Windows username/password may be incorrect
  • Scenario #3 - The share or NTFS permissions are incorrect
    • In other words, the Windows networking share/NTFS (or Linux networking SAMBA share) configuration is not allowing the relevant Windows user to have full read/write permissions to that location.
  • Scenario #4 - Controller application server was installed on a 64-bit operating system, and the version of Controller is earlier than 8.5.1414 (also known as 8.5.1 or 8.5 RP1).
    • In this case the problem is caused by a known bug.
    • For more details, see separate IBM Technote #1365164.
  • Scenario #5 - Controller application server's web server (IIS) has the incorrect settings for its IIS Application Pool.
    • For example, the bitness (32 or 64bit) is configured incorrectly.
    • For more details, see separate IBM Technote #1980834.
  • Scenario #6 - (Controller 10.1.1 or earlier) - Registry key '...\FrangoController\Settings' has grown so large that it is causing Controller to timeout, and therefore not read the required 'shares' key correctly
    • For more details, see separate IBM Technote #1993236.

Diagnosing The Problem

Depending on the circumstances, it may be possible to narrow down which scenario you are suffering from by analysing the error message slightly:

Scenario #1
Notice how the message contains the distinctive string "Share: User: Psw: *****":


    Information
    Standard Error
    Number: 5
    Source: FrangoDirect.ExcelLinkD.FetchValuesBulk#ControllerProxyClient
    Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. -?? System.IO.FileNotFoundException:
    File not found Server: Share: User: Psw: ***** Transfer: 0 Prefix: ?K

Scenario #2 & 3
Here is a real-life example:
    Number: 5
    Source: FrangoDirect.ExcelLinkD.FetchValuesBulk#ControllerProxyClient
    Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.IO.FileNotFoundException: File not found
    at Cognos.Controller.Proxy.CCRWS.ExcelLinkB_FetchValuesBulk(String sGuid, String sKeys, String sMcurr, Boolean bLocLang, String sUser, String sRep, Boolean bIsLnk, String sSortOrd, String sParams)
    --- End of inner exception stack trace ---
    at Microsoft.VisualBasic.ErrObject.Raise(Int32 Number, Object Source, Object Description, Object HelpFile, Object HelpContext)
    at Cognos.Controller.Common.RaiseErrCli.RaiseError(Int32 lErrNo, String sErrSource, String sErrDesc, String sErrHelpFile, Int32 lErrHelpContext)
    at Cognos.Controller.Direct.ExcelLinkD.FetchValuesBulk(String sKeys, String sMcurr, Boolean bLocLang, String sRep, Boolean bIsLnk, String sSortOrd, String sParams)
    at Cognos.Controller.Reports.ExcelLink.RunReportLnkBulk()

Resolving The Problem

Workaround:

As a temporary workaround, disable the use of ERO / Optimise2 on the affected reports.

  • In other words, remove the Excel 'Name' called 'Optimise2' from cell A1 of the spreadsheet.
  • For full details, see separate IBM Technote 1347048.

Fix:

Scenarios 1, 2 & 3:

Correctly configure the section 'Enhanced Reporting Optimisation' inside Cognos Controller Configuration as per the official documentation.

  • For full details, see separate IBM Technote 1347048.


  • Steps:
    1. Launch Cognos Controller Configuration on the Controller application server
    2. Open the section "Enhanced Reporting Optimisation"
    3. Ensure that the correct Windows user/password are used
    4. Ensure that the Windows share permissions are correct (on the relevant folder on the database server) so that the user has read/write access to the folder
    5. Ensure that the Windows NTFS permissions are correct (on the relevant folder on the database server) so that the user has read/write access to the folder

Scenario 4:


Upgrade to Controller 8.5.1414 (also known as 8.5.1 or 8.5 RP1) or later.
  • For more details, see separate IBM Technote #1365164.

Scenario 5:

Modify the relevant IIS application pool (the one that is hosting the Controller application).

  • For more details, see separate IBM Technote #1980834.

Scenario 6:

Delete the contents of the following key: HKLM\SOFTWARE\Wow6432Node\VB and VBA Program Settings\FrangoController\Settings

  • For more details, see separate IBM Technote #1993236.

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Historical Number

1031026

Document Information

Modified date:
15 June 2018

UID

swg21370796