IBM Support

Error 'Insufficient memory to continue the execution of the program' when launch Data Entry

Troubleshooting


Problem

User clicks on 'Company - Data Entry - Reported Values'. Error message appears

Symptom

Information
Standard Error
Source: ControllerForms
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. --->
System.OutOfMemoryException: Insufficient memory to continue the execution of the program.
at FrDataEntryRepValB.DataEntryRepValClass.GetPopupData(String dGuid, String sUser)
at Cognos.Controller.Proxy.CCRWS.DataEntryRepVal_GetPopupData(String sGuid, String sUser)
--- End of inner exception stack trace ---

Cause

Application server has run of of memory/resources.

This IBM Technote relates to the scenario where there is a memory leak on the Controller application server. This means that, over time, there is less-and-less memory available to run the Controller system. Eventually there is too little available memory on the application server for the system to carry on functioning correctly.

There are many potential causes for memory leaks (for example Microsoft bugs caused by not using the latest Windows service packs). However, this IBM Technote specifically relates to the customer using Controller 8.3.x.

In this case, the most likely root cause is a memory leak caused by a code production problem in the 'reporting' component ('Cognos 8 BI') of Controller.

  • For more information, see separate IBM Technote #1365078.

Environment

Customer using Cognos BI 8.3 components, for example the ones that are shipped with the Controller 8.3.x. product.

Diagnosing The Problem

There are other potential causes (for the lack of resources on the application server), but if the problem is solved by simply rebooting the application server, then this almost certainly proves

Resolving The Problem

Fix:
Upgrade to Controller 8.4 (released November 2008) or later.

Workaround:


Obtain a short period of downtime, and reboot the application server.

TIP:
  • As a proactive precaution, it is recommended that the application server is automatically rebooted (via a scheduled task) weekly (for example, every Sunday morning at 3am). This should hopefully ensure that the memory leak does not build up sufficiently to cause this issue.
  • Alternatively, the problem may be temporarily solved by simply scheduling a restart of the Windows service called 'Cognos 8' during a period of downtime.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.3","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1041444

Document Information

Modified date:
15 June 2018

UID

swg21367340