Troubleshooting
Problem
User launches a consolidation. Consolidation fails, with an error message.
Symptom
Event Log - Application server
There are three separate events recorded:
(1)
Event Type: Warning
Event Source: VBRuntime
Event Category: None
Event ID: 1
Date: 05/11/2007
Time: 17:14:14
User: N/A
Computer: APPSERVER
Description:
The VB Application identified by the event source logged this Application FrMiscBT: Thread ID: 2208 ,Logged: Error occured at 11/5/2007 6:14:14 PM in FrMiscBT, Error No=1150, Source=FrMiscBT.ConsBusinessT.RunConsol, Description=Not enough memory for file map., HelpFile= HelpContext=0
(2)
Event Type: Warning
Event Source: VBRuntime
Event Category: None
Event ID: 1
Date: 05/11/2007
Time: 17:14:15
User: N/A
Computer: APPSERVER
Description:
The VB Application identified by the event source logged this Application FrBatchBT: Thread ID: 2208 ,Logged: Error occured at 11/5/2007 6:14:15 PM in FrBatchBT, Error No=1150, Source=FrBatchBT, Description=Application-defined or object-defined error (Error occured within method=RunConsol in the module with progid=FrMiscBT.ConsBusinessT), HelpFile= HelpContext=0
(3)
Event Type: Warning
Event Source: VBRuntime
Event Category: None
Event ID: 1
Date: 05/11/2007
Time: 17:14:14
User: N/A
Computer: APPSERVER
Description:
The VB Application identified by the event source logged this Application FrMiscBT: Thread ID: 2208 ,Logged: Error occured at 11/5/2007 6:14:14 PM in FrMiscBT, Error No=1150, Source=FrMiscBT.ConsBusinessT.RunConsol, Description=Not enough memory for file map., HelpFile= HelpContext=0
Cause
'Not enough memory for file map' is a Visual FoxPro error which indicates that the application is trying to build a temporary file that is larger than VFP's physical file size limit.
There are several potential causes for this:
- Scenario #1 - Code production problem in Controller 2.3 MR1 sp5 or earlier
- Scenario #2 - Code production problem in Controller 2.3 MR1 sp12 or earlier
- Scenario #3 - Limitation in Controller 2.x, which is solved by migrating to Controller 8.x
- Scenario #4 - Application server may be overloaded by running too many simultaneous consolidations.
Resolving The Problem
Workarounds:
Depending on circumstances, it is possible that some/all of the following workarounds will allow users to carry on using the system:
- Re-run the same consolidation exactly as before
- Re-run the same consolidation as before, but this time perform a 'consolidation by steps' (instead of running a 'consolidation by status')
- Obtain a short period of downtime, and then reboot/restart the Controller application server (and ideally also the SQL server). Afterwards, re-run the same consolidation exactly as before.
Long-term Fix
Scenario#1
Upgrade to Controller 2.3 MR1 sp6 or later.
TIP: Ideally, to minimise the risk of the problem re-occurring, migrate to Controller 8.x.
Scenario#2
Upgrade to Controller 2.3 MR1 sp13 or later.
TIP: Ideally, to minimise the risk of the problem re-occurring, migrate to Controller 8.x.
Scenario#3
Migrate Controller 2.x system to Controller 8.x.
Scenario#4
Ensure that only one consolidation is run simultaneously.
- Ensure that you are using the batch queue (to run your consolidations in sequence, via a scheduled process).
- In other words, make sure you have *not* disabled the batch queue by using the unsupported server preference 'BATCHMODE'
- Ensure you *only* have one batch service running
- To check, logon to the Controller application server
- Right-click on 'My Computer' and choose 'Manage'
- Open the 'Services' section
- Ensure that there is only one service called 'Frango Batch Server' listed there.
Related Information
Historical Number
1037133
Was this topic helpful?
Document Information
Modified date:
15 June 2018
UID
swg21364764