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** Troubleshooting ** 'ORA-12541: TNS:no listener' errors, for example inside Event Log

Troubleshooting


Problem

User tries to launch Controller. User receives error message on screen. If they look at their client PC's 'application' Event Log, there is an entry there, corresponding with the time when they tried to logon. On the Controller application server, there are periodic VBRUNTIME errors.

Symptom

Client PC screen:

An error occurred while trying to access the server

Client PC Event Log:

Event Type: WarningEvent Source: Cognos ControllerEvent Category: NoneEvent ID: 0Date: 1/31/2008Time: 10:20:10 AMUser: N/AComputer: PCNAMEDescription:Error occured at 1/31/2008 10:20:10 AM in Cognos Controller, Error No=5, Source=FrangoDirect.ServerInfoD.GetServerInfo#ControllerProxyClient, Description=System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Runtime.InteropServices.COMException (0x80004005): ORA-12541: TNS:no listener at FrServerB.ServerInfoClass.GetServerInfo(String sGuid, String sUser) at Cognos.Controller.Proxy.CCRWS.ServerInfo_GetServerInfo(String sGuid, String sUser) --- End of inner exception stack trace ---, HelpFile= HelpContext=0

Application Server Event Log:

    Event Type: Warning
    Event Source: VBRuntime
    Event Category: None
    Event ID: 1
    Date: 1/31/2008
    Time: 10:08:02 AM
    User: N/A
    Computer: SERVERNAME
    Description:
    The VB Application identified by the event source logged this Application FrSrvFunc: Thread ID: 3424 ,Logged: Error occured at 1/31/2008 10:08:02 AM in FrSrvFunc, Error No=-2147467259, Source=Server function:Db_CreateConnection(..) , Description=ORA-12541: TNS:no listener, HelpFile= HelpContext=0

And:
    Event Type: Error
    Event Source: VBRuntime
    Event Category: None
    Event ID: 1
    Date: 1/31/2008
    Time: 10:08:02 AM
    User: N/A
    Computer: SERVERNAME
    Description:
    The VB Application identified by the event source logged this Application FrSrvFunc: Thread ID: 3424 ,Logged: Connection Error: Udl=File Name=C:\Program Files\cognos\c8\Data\DEVELOPMENT.Udl But security is OFF!!!
    Error No=-2147467259, Source=OraOLEDB, Description=ORA-12541: TNS:no listener, Native Error=12541, Sql State =

In addition, if using TNSPING, you may get the error 'TNS-12541: TNS: no listener'.

Cause

There are many potential causes for 'ORA-12541 TNS:no listener' errors. For example:

  • Scenario #1 - Tnsnames.ora file does not have the correct information required to connect to
the Oracle instance
    • See separate IBM Technote 1346169 for more details
  • Scenario #2 - Oracle server has more than one network card, but only 1 card is configured
    • See separate IBM Technote 1353150 for more details
  • Scenario #3 - IBM Cognos server has Oracle 9 client installed, but the data source is hosted on an Oracle 10 database server.
  • Scenario #4 - Server has Symantec Firewall installed. By default, this blocks TNSPING
    • See separate IBM Technote 1372042 for more details
  • Scenario #5 - Problem with sqlnet.ora file
    • See separate IBM Technote 1342952 for more details

However, this IBM Technote specifically deals with the scenario where the Oracle server was not operational/misconfigured. In one customer's specific case, the Oracle server's listener was not configured correctly.

Resolving The Problem

Ask Oracle DBA to check the Oracle server, to solve connection problem.

NOTE: Oracle is a third party (non-IBM) piece of software. IBM cannot give any official advice on third-party (non-IBM) products.

However, in one customer's case, the problem was solved by deleting and re-creating the Oracle Listener.

Steps to delete/re-create an Oracle Listener:

  1. Obtain a short period of downtime
  2. Logon to Oracle server as an administrator
  3. Click "Start - Programs - Oracle - OraDb10g_home1 - Configuration and Migration Tools - Net Configuration Assistant"
  4. Select "Listener configuration" and choose 'Next'
  5. Choose 'Delete'.
  6. Use the wizard to delete the listener(s).
  7. Repeat steps 4, 5 and 6 until *all* listeners have been deleted
  8. Choose 'Add' then 'Next'
  9. Give the listener a suitable name (for example default = LISTENER) and click 'Next'
  10. Ensure that the 'Selected Protocols' is correct (typically, this should only include 'TCP') and click 'Next'
  11. Choose the TCP port (typically accept the default '1521') and click 'Next'
  12. Finish
  13. Test.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.2","Edition":"All Editions","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1038229

Document Information

Modified date:
15 June 2018

UID

swg21361712