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** Troubleshooting** Error '(0x800A0005): Invalid procedure call or argument' when using Data Entry - Reported Values

Troubleshooting


Problem

User launches Excel. User logs into Controller, via the Excel add-in menu 'Controller - Login'. User launches 'Data Entry - Reported Values'. User opens a form (e.g. 'ZSTB'). Scenario #1 - User receives error message.

Symptom

Information
Standard Error
Source: ControllerForms
Description: System.Web.Services.Protocols.SoapException: Server was unable to process request. ---> System.Runtime.InteropServices.COMException (0x800A0005): Invalid procedure call or argument
at FrDataEntryRepValB.DataEntryRepValClass.GetDataEntryForm(String sGuid, String sUser, String sPeriod, String sAct, String sConsType, String sGroup, String sCompany, String sCurrType...

Cause

There are many potential causes of the error message "(0x800A0005): Invalid procedure call or argument":

  • Scenario #1 - There is a problem with the form
    • For example, some of the accounts were not summed into the total account.
  • Scenario #2 - Invalid company code in form
    • For example, the free form had 'hard coded' company code that was then used for an FPutval formula. The company code was invalid so the error was generated.
    • For more information, see separate IBM Technote #1358597.
  • Scenario #3 - Invalid cache files on the end user's client device
    • Clear local Controller cache.
  • Scenario #4 - Invalid owner of SQL stored procedure(s)
    • See separate Technote #1586677 for more details.

Diagnosing The Problem

The problem will occur at a different stage, depending on the scenario:

  • Scenario #1 - Error occurs when user tries to open data entry form
    • Problem affects ALL users
  • Scenario #2 - Error occurs when user presses 'save' to save changes inside data entry form
  • Scenario #3 - Error occurs when user tries to open data entry form
    • Problem only affects ONE user
    • See separate IBM Technote #1395468

Resolving The Problem

Scenario #1

Modify the accounts/form to ensure that all accounts are summed correctly into the total account.

Scenario #2


See separate IBM Technote #1358597.

Scenario #3


Ask the 'bad' user to perform the following steps:
  1. Launch Controller as normal
  2. Click "Maintain - Special Utilities - Clear Local Cache'
  3. When asked "Do you want to clear the local cache?" click OK
  4. Test.


Scenario #4 - Modify SQL database so that stored procedure(s) have correct owner.
See separate Technote #1586677 for more details.

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Historical Number

1039665

Document Information

Modified date:
15 June 2018

UID

swg21347873