IBM Support

'The configuration parameters have been changed' or 'Could not find a part of the path ... ccr.config' when launching Excel link

Troubleshooting


Problem

User launches Microsoft Excel. User clicks "Controller - Logon" (to logon to the Excel link). User receives error message.

Symptom

The message varies depending on the environment and Controller version

  • Modern versions (for example Controller 10.1 on Windows 7):

IBM Cognos Controller Link
The configuration parameters have been changed. Please contact your system administrator.



IBM Cognos Controller Link
Could not find a part of the path 'C:\Users\<username>\AppData\Roaming\Cognos\ccr\ccr.config'.
OK
  • Older versions (for example Controller 8.3 on Windows XP):

Cognos 8 Controller Link
Could not find a part of the path 'C:\Documents and Settings\<username>\Application Data\Cognos\ccr\ccr.config'.
OK

Cause

There is no file "ccr.config" inside the end user's Windows profile.

  • This is a file that is created when the 'main' Controller client ("CCR.EXE") is first launched.

There are many possible causes for this, for example:
  • Scenario #1 (most likely) - User has never launched the 'main' Controller client (CCR.EXE) before.
  • Scenario #2 - User has a brand-new (empty) Windows user profile, or a profile with which they have never launched CCR.EXE
    • This is more likely to be true if the customer is deploying Controller via Citrix (or Terminal Server) and the system is configured to use 'standard' (not 'Roaming') profiles. For example if there are 4 Citrix servers, then there would be 4 separate/different Windows user profiles.

More Information:
When the user first launches the main Controller software (CCR.EXE), it populates the end user's Windows profile (%appdata%\cognos\ccr) with a file "ccr.config".
  • This file stores the user's Controller settings.
  • If this file does not exist, the Microsoft Excel Controller add-in link gives an error message.

Resolving The Problem

Fix:
Ask end-users to launch the main Controller program (CCR.EXE) before they launch Microsoft Excel.

Workaround
In some (rare) circumstances/environments, customers may wish to automatically copy a pre-poulated 'blank/template' ccr.config file to the user's profile.

Steps:
This method is typically useful inside a Citrix/Terminal Services environment. A suggested method is:

  1. Logon to the Citrix server using a brand new (never used before) 'test' Windows user (brand new Windows profile)
  2. Launch Controller
  3. Immediately exit Controller after logging on (=> this creates a 'blank' template CCR.CONFIG file inside %appdata%\cognos\ccr folder
  4. Copy this file to a sensible 'source' folder location (e.g. C:\UTILS\SCRIPTS)
  5. Use NOTEPAD.EXE to modify the file C:\WINDOWS\SYSTEM32\USRLOGON.CMD
  6. Add a few lines to the top, so that it automatically (a) creates the folder %appdata%\cognos\ccr folder during logon, and then (b) copies the 'blank/template' CCR.CONFIG file to the user's profile

For example:
    @Echo off
    REM Following added <date> to make Cognos Controller
    REM Excel add-in to not give error message
    REM when Controller CCR.EXE has not been launched beforehand

    C:
    cd %appdata%
    md cognos
    cd cognos
    md ccr
    cd ccr
    copy c:\utils\scripts\ccr.config c:

    REM End of modifications

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1;8.5;10.1;10.1.1","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1039398

Document Information

Modified date:
15 June 2018

UID

swg21347817