IBM Support

Error 'The Excel-link is not installed' when using 'Data Entry - Reported Values'

Troubleshooting


Problem

User clicks on 'Data Entry - Reported Values' inside Controller. This launches Excel, but when it has opened an error message appears.

Symptom


    Information
    The Excel-link is not installed.
    OK

In addition, you may also see the following error when you launch Excel directly from the Start Menu:
    Source: Cognos Controller Link
    Description: That assembly does not allow partially trusted callers.
    Function: EnableMenu
    Err: 0x8013150a

    Source: Cognos Controller Link
    Description: Request for the permission of type 'System.Security.Permissions.SecurityPermission, mscorlib,Version=2.0.0.0, Culture=neutral, PublicKey Token=b77a5c561934e089' failed.
    Function: DpLoginEx
    Err: 0x8013150a
    Extra: ADM

    You are not logged in.

Plus in the Event Viewer application log:
    Source: Cognos Controller
    Event ID: 0

    Description:
    Error occurred at 28/07/2008 11:19:04 in Microsoft Office 2003, Error No=5,
    Source=FrangoDirect.ConnectionDirect.IntegrationType#System.Configuration, Description=Configuration system failed to initialize, HelpFile=
    HelpContext=0

Cause

There are many potential causes for the error 'The Excel-link is not installed'. For more examples, see separate IBM Technote #1396195.

This Technote shall specifically deal with the scenario where Excel is trying to use the wrong version of .NET Framework and/or the client PC's .NET Framework version's security has not been correctly configured to trust the Controller webserver.

Typically this is because the client device (for example the end user's PC) has multiple versions of Microsoft .NET Framework installed. By default, Microsoft Excel will attempt to use the latest version of the Microsoft .NET Framework client that is installed.
However:

  • Controller 8.1.x can only use .NET 1.1 SP1
  • Controller 8.2 -> 10.2 uses .NET 2.0 (SP1).

Resolving The Problem

Force Microsoft Excel to use the correct version of .NET Framework by using a special file 'EXCEL.EXE.CONFIG' located inside the same folder where EXCEL.EXE is installed.

    TIP: Ensure that all users have at least 'read' NTFS permissions to the EXCEL.EXE.CONFIG file.

Afterwards, ensure that the .NET security trust has been configured correctly.

Steps:
  1. Perform the steps listed inside separate IBM Technote #1347249
  2. Afterwards, create a .NET trust. For example, for Controller 8.2/8.3 and 8.4, perform the following steps:
  • Logon to client PC as an administrator
  • Start - Run
  • CMD <Enter>
  • Enter the following commands:

    • c:
      cd %windir%\Microsoft.NET\Framework\v2.0.50727
      caspol -q -m -ag "All_Code" -url http://<CASUrl>/* FullTrust -name "Controller_<CASUrl>" -d "Controller_<CASUrl>"
  • TIP: Replace <CasUrl> with the value that you have inside Controller Configuration. For example:
    • caspol -q -m -ag "All_Code" -url http://servername.company.com/* FullTrust -name "Controller_servername.company.com" -d "Controller_servername.company.com"

    TIP: If using Controller 8.2, 8.3 or 8.4, then can also refer to attached document '02. How to install the IBM Cognos Controller 8.4 client on a user's PC - Proven Practice.pdf'.

    [{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.4;8.3;8.2;8.1","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

    Historical Number

    1039338

    Document Information

    Modified date:
    15 June 2018

    UID

    swg21347807