Troubleshooting
Problem
Customer has an issue with Controller, where the cause has been traced to the Frango VFP files not being installed correctly on the Controller application server. How can these files be re-registered correctly, without uninstalling/re-installing Controller server?
Symptom
Bad Server:
Inside Component services, the relevant VFP components are missing.
Good Server:
Compare the above, with a working server (below):
Cause
Missing or unregistered VFP runtime DLL files on Controller application server.
- Typically this is caused by APAR PH24802 (see separate IBM Technote #6198780).
Environment
This IBM Technote specifically relates to Controller 10.3, running on Windows Server 2016.
- However, the advice can generally be used for other versions (with perhaps a few slight alterations).
Resolving The Problem
Ensure that the VFP shared DLL files are copied over to the application server, and re-register these files in Windows.
4. Type the following:
5. Type the following:
6. Click 'Start - Windows Administrative Tools - Component Services'
7. Expand 'Computers - My Computer - COM+ Applications - IBM Cognos Controller Consolidation - components'
8. Right-click on 'Components' and choose 'New - Component':
9. Click Next
10. Click 'Install New Components'
11. Browse to: "C:\Program Files\IBM\cognos\ccr_64\server\frangovfp.dll"
12. Click Next:
13. Click Finish
14. Test.
Steps:
The following steps relates to Controller 10.3, installed into the default location, running on Windows Server 2016.
- Some instructions may need to be modified slightly, if your environment is different.
1. Logon to your Controller application server as a Windows administrator
2. Check that the following file exists: C:\windows\SysWOW64\msvcr71.dll
If not, then:
- Browse to this folder: C:\Program Files\IBM\cognos\ccr_64\server
- Copy the file msvcr71.dll into this folder: C:\windows\SysWOW64
3. Check that the following 4 files exist inside C:\Windows\SysWOW64\server:
- vfp9r.dll
- vfp9renu.dll
- vfp9t.dll
- vfpcom.dll
3. Launch a command prompt, by right-clicking on the 'Start' button and choosing 'Command Prompt - Admin"
4. Type the following:
- cd c:\windows\syswow64\server
REGSVR32 VFPCOM.DLL
5. Type the following:
- regsvr32 vfp9r.dll
regsvr32 vfp9t.dll
6. Click 'Start - Windows Administrative Tools - Component Services'
- Alternatively, launch the following: %windir%\system32\comexp.msc
7. Expand 'Computers - My Computer - COM+ Applications - IBM Cognos Controller Consolidation - components'
- Notice how there is probably currently nothing in there (it is empty):
8. Right-click on 'Components' and choose 'New - Component':
9. Click Next
10. Click 'Install New Components'
11. Browse to: "C:\Program Files\IBM\cognos\ccr_64\server\frangovfp.dll"
12. Click Next:
13. Click Finish
- The screen should now look similar to:
14. Test.
Related Information
[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"10.3","Edition":"","Line of Business":{"code":"LOB10","label":"Data and AI"}}]
Historical Number
1034011
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Document Information
Modified date:
29 April 2020
UID
swg21347240