IBM Support

Unable to launch Controller or download client - user receives blank page / white page

Troubleshooting


Problem

User has problems when launching the Controller client.

Symptom

Depending on the environment (and how you chose to launch Controller), the end user will see slightly different symptoms. For example, you may find that one the following descriptions fits the problem best:

  1. The Controller client fails to start - it does not appear to launch anything (nothing happens). There is no error message
  2. Internet Explorer screen changes to a white page (blank screen). The only thing visible is http://servername/ibmcognos/cgi-bin/cognos.cgi (or http://servername/ibmcognos/cgi-bin/cognosisapi.dll depending on how the gateway is configured)
  3. The Controller client appears to start launching, but an error message appears (see below):
      Microsoft IE Execute shell
      Microsoft IE Excecute shell has encountered a problem and needs to close.
      We are sorry for the inconvenience.
    TIP: There is a deliberate misspelling of 'Microsoft IE Execute shell has encountered a problem and needs to close'.

    In addition, the 'details' section may contain text similar to the following:
      EventType : clr20r3
      P1 : ieexec.exe
      <...>
      P9 : system.security.security

Cause

There are many different potential causes for the symptom of a 'blank/white screen'. For more examples, see separate IBM Technote #1347103.

This IBM Technote specifically relates to the following potential scenarios:

  • Scenario #1 - The client PC's Microsoft Internet Explorer has not been configured to trust the Controller website, so will not allow the download of the Controller client software code
  • Scenario #2 - The client PC's Microsoft .NET Framework client has not been configured to trust the Controller website, so will not allow the running of the Controller client software code.

TIP:
  • For complete details of client installation best practices, see the latest version of the 'How to install the Controller client' Proven Practice document, available from the IBM Developerworks (proven practices) website
  • For the sake of convenience, the Controller 8.4 version ('02. How to install the IBM Cognos Controller 8.4 client on a user's PC - Proven Practice.pdf') has been attached to this IBM Technote. In particular, see pages 10, 11 and 12.

Diagnosing The Problem

Before proceeding, it is important that you ensure that you know the value of your CASUrl. Therefore, you must perform the following steps:

  1. Logon to Controller application server as administrator
  2. Launch 'Controller Configuration' from the Start Menu
  3. Open section 'Client Distribution Server - Client Distribution Server Config'
  4. Locate value of 'CASUrl' (for example 'http://servername.company.com/ibmcognos/controllerbin')

The 'servername' value that comes between 'http://' and '/ibmcognos' (in the above example it is 'servername.company.com') will be important later.

Resolving The Problem

Scenario #1 - Internet Explorer trust problem
Reconfigure the client PC's Internet Explorer so that:

  • The Controller webserver is inside the 'trusted zone' of Internet Explorer
  • Internet Explorer's security options are configured to allow 'automatic prompting for file downloads'

Steps:
Part One: Add the Controller webserver into the 'trusted zone' of Internet Explorer
  1. On the client PC, launch Microsoft Internet Explorer
  2. Click 'Tools - Internet Options'
  3. Select 'Security' tab
  4. Highlight 'Trusted sites' and then click 'sites'
  5. Ensure that box 'Require server verification...' is NOT ticked
  6. Inside the box 'Add this website to the zone' add the Controller website which users are using (for example 'http://servername') and click 'Add'
  7. If the value of CASUrl (see earlier) is different from this website, repeat the previous step but for the CASUrl (for example 'http://servername.company.com')
  8. Click 'Close' then 'OK'

Part Two: Configure Internet Explorer to allow 'automatic prompting for file downloads'
  1. Launch Internet Explorer
  2. Click 'Tools - Internet Options'
  3. Select 'Security'
  4. Select 'Trusted Sites'
  5. Select 'Custom level'
  6. Under the heading 'downloads' select: 'Allow prompting for file Downloads'
  7. Click 'OK' then 'OK'
  8. Test.

Scenario #2 - Microsoft .NET trust problem
Configure client PC 's .NET Framework (client) to trust the Controller web server

Steps:
Perform the following:
  1. Logon to client PC as an administrator
  2. Start - Run
  3. CMD <Enter>
  4. Enter the following commands:
    c:
    cd %windir%\Microsoft.NET\Framework\v2.0.50727
    caspol -q -m -ag "All_Code" -url http://<CASUrl>/* FullTrust -name "Controller_<CASUrl>" -d "Controller_<CASUrl>"

TIP: Replace <CasUrl> with the value that you have inside Controller Configuration
For example:
    caspol -q -m -ag "All_Code" -url http://servername.company.com/* FullTrust -name "Controller_servername.company.com" -d "Controller_servername.company.com"

02. How to install the IBM Cognos Controller 8.4 client on a user's PC - Proven Practice.pdf

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1;8.5;8.4;8.3;10.1;10.1.1","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1030075

Document Information

Modified date:
15 June 2018

UID

swg21346813