IBM Support

Unable to view system reports - error 'The page cannot be displayed' inside Internet Explorer

Troubleshooting


Problem

User attempts to run a standard report (also known as 'system report') inside Controller. The expected (Internet Explorer) window appears, with the initial message 'Please wait, loading the report...'. However, instead of the report appearing shortly afterwards as expected, the screen hangs on this message or alternatively is followed by an error message.

Symptom

The exact error message will vary according to environment (client's Internet Explorer version, server's IIS webserver version) but one example is:

The page cannot be displayed

Cause

The Controller application server does not have the correct name stored for the IBM Cognos 8 BI Report Server.

Typically, the root cause of this is that (during a recent install or upgrade of Controller), a step was missed, which caused this setting not to be saved in the system.

VITAL: It is vitally important that the icon 'save' (inside the Report Server section of 'Controller Configuration) is pressed during every Controller installation (or upgrade). If this is not done, then the registry key will not be created/saved.

Diagnosing The Problem

The setting for the Report Server is stored (on the application server) inside the following registry key:

  • 32-bit operating systems: HKEY_LOCAL_MACHINE\SOFTWARE\VB and VBA Program Settings\FrangoController\Shares
  • 64-bit operating systems: HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\VB and VBA Program Settings\FrangoController\Shares

The value is stored inside a REG_SZ entry 'CRNPath', with a value such as:

Resolving The Problem

Save the 'Report Server' setting correctly (inside 'Controller Configuration' on the Controller Web Services (application) server).

Steps:

  1. Logon to the Controller application server as an administrator
  2. Launch 'Controller Configuration' from the Start Menu
  3. Click on the 'Report Server' section
  4. If the value for the 'Report Server' refers to http://localhost/... then modify it to the Cognos 8 report server name (NetBIOS or FQDN as appropriate). For example: http://CONTROLLERSVR/cognos8/cgi-bin/cognos.cgi
  5. If the value for the 'Report Server' refers to http://<correct server name>/... then modify it slightly by simply overtyping one letter (for example re-type the 'h' in 'http') to make the 'save' icon appear
  6. If the value for the 'Dispatcher URI' refers to http://localhost/... then modify it to the Cognos 8 report server name (NetBIOS or FQDN as appropriate).
  7. Click on 'save' icon at the top left of the screen
  8. Test

TIPS:
  • You only need to change (delete and retype) one letter (of either of the two sections), to make the save icon 'active' (so you can use it)
    • Therefore, during an install/upgrade, you typically must delete one character from the 'report server' section, and then retype it. You will now be able to press 'save'
  • It is also possible to manually modify the value for 'Dispatcher URI' . The following instructions are based on the default locations for Controller 8.x:
    • START - RUN
    • notepad c:\program files\cognos\c8\controllerproxyserver\web.config
    • Search for the key 'crnDisp' and modify appropriately.

[{"Product":{"code":"SS9S6B","label":"IBM Cognos Controller"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"Controller","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.5.1;8.5;8.4;8.3;10.1;10.1.1","Edition":"Not Applicable","Line of Business":{"code":"LOB10","label":"Data and AI"}}]

Historical Number

1026597

Document Information

Modified date:
15 June 2018

UID

swg21346377