IBM Support

Intermittent error when running reports: UDA-SOR-0001 Unable to allocate memory

Troubleshooting


Problem

UDA-SOR-0001 Unable to allocate memory error appearing intermittently or when server is experiencing peak user activity.  Error can appear in Details section of error screen or in the Cognos Server logs.

Symptom

Examples:
QE-DEF-0177 Error executing operation 'sqlOpenResult' Status='-28'
UDA-SQL-0114 The cursor supplied to the operation "APICursor::OpenResult" is inactive.
UDA-SOR-0001 Unable to allocate memory.

REQ-DEF-0177
An error occurred while performing operation 'sqlOpenResult' status='-237'.
UDA-SOR-0001 Unable to allocate memory.

Cause

Cognos server dispatchers report processes (BIBusTKServerMain) do not have enough memory for the size or number of the report(s) being run leading to the error, or a report is complex and requires more that is available to report process.  Another possible cause is insufficient drive space in the location used by Cognos Analytics for temp files.

Resolving The Problem

Solution 1:
Increase the number of Interactive and Batch report processes. By optimizing the environment, requests are spread over a number of BiBus processes, and the memory issue may no longer occur.
1. Go to Administration console, Configuration tab, Dispatchers and services
2. Go to properties of the Configuration level to apply to all dispatchers, or properties of a specific dispatcher
3. Click Settings tab.  Increase from default 2 processes for the following settings:
Maximum number of processes for the batch report service ( for background or scheduled reports)
Maximum number of processes for the report service (for interactively run reports)
Click Ok and restart the Cognos Service
Solution 2:
Decrease the sort memory setting in Cognos Configuration from the default value (32 MB). This setting applies to each BiBusTkServerMain Process, so it gets multiplied by the configured number of Report Processes.
1. Open Cognos Configuration, and select Environment from the Explorer Bar
2. Change the value of the Sort buffer size in MB to a smaller amount.
3. Save the configuration.
4. Stop and restart the Cognos service.
Solution 3:

Confirm that there is free space available on the drive that contains the temporary directory used by IBM Cognos components.  During processing of reports temp directory is used to store the information temporarily. It is hard to determine how much free space is required to be used by the Cognos temp directory. However, it is recommended to have at least 5 GB of free space on the drive.

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Historical Number

1031683

Document Information

Modified date:
16 July 2020

UID

swg21341779