Troubleshooting
Problem
Unable to export a DB2 content store using the deployment utility in Cognos Connection.
Symptom
[IBM][CLI Driver][DB2/6000] SQL0973N Not enough storage is available in the "APP_CTL_HEAP_SZ" heap to process the statement. SQLSTATE=57011
CM-REQ-4313 An error occurred during an export operation.
CM-SYS-5092 Content Manager failed while returning the query results.
Cause
The 'APP_CTL_HEAP_SZ' database parameter for the content store database is set too low.
Resolving The Problem
Increase the APP_CTL_HEAP_SZ parameter (on the DB2 database).
TIP: If this does not solve the problem, then the Buffer Pool pages in the Database are still set too low. Increasing these from the default size 250 to higher also resolves this error.
Steps to increase the "APP_CTL_HEAP_SZ" value:
1. Start the DB2 command line processor.
- On Windows this can be done from Start -> Programs -> IBM DB2 -> command line tools -> command line processor.
- Otherwise from a command prompt, if the DB2 environment variables are set, you can just type: 'db2' to start the command line processor.
2. From the command line prompt, connect to the content store database:
connect to <contentstoredatabasename> user <userid> using <password>
3. Retrieve the current APP_CTL_HEAP_SZ value:
get database configuration
4. Increase the APP_CTL_HEAP_SZ :
UPDATE DATABASE CONFIGURATION FOR <contentstoredatabasename> USING APP_CTL_HEAP_SZ <newvalue>
5. Restart Cognos.
Steps to increase the Buffer Pool:
1. Open the DB2 Control Center
2. Go to Content Store database, and select Buffer Pools Folder.
3. Two buffers are listed : IBMDEFAULTBP , and CMBUFFER or your chosen buffer name for your content store.
4. Increase the Page Size selection in both from the default 250 pages. Start by doubling the value.
Note that further information and suggestions on values for these settings should be obtained from the IBM documentation.
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Document Information
Modified date:
24 February 2020
UID
swg21340038