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HTTP plug-in failures might prevent the web server from starting

Troubleshooting


Problem

There are several causes for the WebSphere web server plug-in "failed to load" error or failures routing requests to the WebSphere Application Server.
The two most frequent errors:
1. The web server plug-in module cannot use DNS to resolve the server hostnames listed in the plug-in configuration file.
2. The web server plug-in log file is larger than 2GB.
If either of these errors occur, the failure is an unrecoverable error that prevents the web server from starting.

Symptom

The plug-in log might contain errors such as the following:
 
ws_transport: transportSetServerAddress: Failed to resolve address
ws_server: serverAddTransport: Failed to initialize server address
ws_config_parser: configParserParse: Failed to parse the config file
ws_common: websphereUpdateConfig: Failed parsing the plugin config file
These errors are an indication that the plug-in cannot resolve the hostname of the WebSphere Application Server defined in the plug-in XML file. Each cluster must have at least one transport that resolves to an IP address for the web server plug-in module to initialize. 
After startup, the web server plug-in does not attempt any name resolution for any of the transports unless the configuration is reloaded. A configuration reload occurs when the plug-in module detects a change to the plugin-cfg.xml file.  To force a reload, edit and save the file with no changes or use the touch command to change the timestamp of the plugin-cfg.xml file.
If there are frequent name changes, define the transports as IP address to prevent DNS resolution or modify the OS hosts file to include the name resolution to avoid DNS failures.

These errors prevent the web server plug-in to not load. The failure is an unrecoverable error and prevents the web server from starting.

Cause

The web server plug-in calls DNS to obtain IP address for the defined application servers. If the IP address cannot be obtained for a server, the plug-in module fails to start.  By default, plug-in initialization failure is considered an unrecoverable error and the web server initialization fails.
If the plug-in custom property, IgnoreDNSFailures, is set to "true", plug-in initialization does not fail due to an unknown IP address unless an IP address cannot be obtained for all servers defined in a single cluster.
The plug-in initialization failure can be modified to allow the web server to continue to initialize without loading the plug-in module when the custom property, KillWebServerStartUpOnParseErr, is set to false.

The other possible cause of a load problem is a plug-in log file that is larger than 2GB. Simply check the size of the plug-in log. If the size is greater than 2GB, delete or rename the log file.

Resolving The Problem

The problem can be resolved by insuring that the system on which the plug-in is running can successfully resolve the hostname of the WebSphere application servers defined in the plug-in config file.

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Document Information

Modified date:
23 December 2021

UID

swg21326077