Troubleshooting
Problem
Attempts to start IBM Rational DOORS database sever service fails resulting in the error "Could not start DOORS DB Server Error 1067: The process terminated ... "
Symptom
The DOORS database server will not start.
Cause
This message indicates that the service did not start because of a problem with the configuration setting for the database server in the registry.
Diagnosing The Problem
Things to check:
- Confirm the location of the data directory to be used and verify the database server registry setting: ServerData matches this value
- Confirm the data directory permission is set to full control for the database server process owner (doorsd.exe)
- Check the Event viewer, application log for error events associated with the DOORS Server process that failed. This can provide more details about the cause for the failure
Two common failure event message are shown below: - DOORS_DB_SERVER: -E-: Error getting exclusive lock on data: lock file failed c:\program files\DOORS\data\servdata.lck
- DOORS_DB_SERVER: -F-: Directory 'c:\program files\DOORS\data' specified by SERVERDATA does not exist
Resolving The Problem
- To fix the problem when the failure has a missing directory:
Create the data folder and restart the service
- To fix the problem when the failure is an error getting an exclusive lock:
Remove the file servdata.dtc and restart the service
Related Information
[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF033","label":"Windows"}],"Version":"8.3;9.0;9.1;9.1.0.2;9.2;9.2.0.1;9.2.0.2;9.2.0.3;9.2.0.4;9.2.0.5;9.3;9.3.0.1;9.3.0.2;9.3.0.3;9.3.0.4;9.3.0.5;9.3.0.6;9.3.0.7;9.4;9.4.0.1;9.5;9.5.0.1;9.5.1;9.5.1.1;9.5.1.2;9.5.2","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]
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Document Information
Modified date:
01 May 2020
UID
swg21324421