IBM Support

"Failed to initialize database" error while migrating a DOORS database

Question & Answer


Question

Attempts to migrate an IBM Rational DOORS database results in the error "Failed to initialize database".

Cause

The contents of the ts folder have become corrupt.

Note: The ts directory (located under">$SERVERDATA/conf/u1000001.dir/web) contains files that represent inserted pictures in modules that were published to DOORS/Net. These are temporary files created when DOORS/Net users open a published module containing a picture or an OLE object.

Answer

Steps to resolve the issue:

  1. Request all users to logout of DOORS
  2. Stop the DDBS for v7.1
  3. Backup the v7.1 database
  4. Ensure that v8.1 DDBS is stopped
  5. Replace the copied database from v7.1 in v8.1
  6. Browse to the path "$SERVERDATA/conf/u1000001.dir/web/ts" and remove all the contents
  7. Start the v8.1 DDBS
  8. Start the client for migration process to continue 7.1, 8.0, 8.1, 8.2 DOORS Server Migration

[{"Product":{"code":"SSKR2T","label":"IBM Engineering Requirements Management DOORS"},"Business Unit":{"code":"BU059","label":"IBM Software w\/o TPS"},"Component":"General Information","Platform":[{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"}],"Version":"9.0;9.1;9.2;9.2.0.1;9.2.0.2;9.2.0.3","Edition":"","Line of Business":{"code":"LOB59","label":"Sustainability Software"}}]

Document Information

Modified date:
01 May 2020

UID

swg21323948