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db_VISTA error 10048 from connect()

Troubleshooting


Problem

This technote explains how to resolve an error, db_VISTA error 10048 from connect(), that can occur when using IBM Rational ClearCase on heavily used VOB server running Microsoft Windows Server 2003.

Symptom

On heavily used Windows 2003 VOB Servers there is an issue where the db_server may be unable to contact the albd_server even if it is running on the same system.


The following error may be seen:
db_VISTA error 10048 from connect()

Cause


This is a WINSOCK error where a process is attempting to use a port that has already been allocated to another process.

Resolving The Problem

Set Windows to allow user processes to connect to additional ports.

REGISTRY EDITS:

This solution contains information about modifying the system registry. Before making any modifications to the Microsoft Registry Editor, it is strongly recommended that you make a backup of the existing registry. For more information describing how to back up the registry, refer to Microsoft Knowledge Base article 256986


Open the Windows Registry and navigate to this key: HKLM\SYSTEM\CurrentControlSet\Services\Tcpip\Parameters

Create a new DWORD called MaxUserPort, set it to 65534 and reboot the server.
This will allow user processes to use the maximum amount of ports available to the system.

[{"Product":{"code":"SSSH27","label":"Rational ClearCase"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"VOB","Platform":[{"code":"PF033","label":"Windows"}],"Version":"7.0.1.2;7.0.1.1;7.0.1;7.0.0.3;7.0.0.2;7.0.0.1;7.0;2003.06.16;2003.06.00","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
16 June 2018

UID

swg21318013