IBM Support

ConnectException occurs with WebSphere Process Server (WPS) on Derby database access

Troubleshooting


Problem

The connection to a Derby database fails after a data source connection is tested using the administrative console. If also fails when a WebSphere Process Server-related system application tries to access the back end. For example, it tries to access the Common database or the Business Process Choreographer database.

Symptom

The information contained in this document has been moved to developerWorks Answers located here. This technote will be archived in 60 days. Please bookmark the new location.

Testing a connection using the administrative console results in the following exception:

java.sql.SQLException: java.net.ConnectException : Error opening socket to server localhost on port 1527 with message : Connection refused: connectDSRA0010E: SQL-State = null, Error code = -4.499. View JVM logs for further details.

The same exception is logged in the server SystemOut.log file and generated first-failure data capture (FFDC) files. In addition, this problem occurs only for data sources that are created in a clustered environment, that is, when using a deployment environment pattern.

Cause

The Derby database server is not started to handle connection requests. It is started after a deployment manager or custom profile is configured to create the necessary databases and tables. The database is not triggered by WebSphere Process Server to start in a clustered environment.

Environment

You have configured a WebSphere Process Server clustered environment using a local or remote Derby database as the back-end system.

Resolving The Problem

The following instructions guide you through the problem-resolution process:

  1. Review the configured data sources or the exception message for the WebSphere Process Server environment and ensure that the host name and port are correct.

  2. Locate the Derby database installation directory. If you use the default database installation that was shipped with the product, the directory is:

    install_root\derby\bin\networkServer

  3. Check if the database server was started already and provide a host name and port if the server is not local to the WebSphere Process Server installation:

    sysinfo.(bat|sh) -h <host> -p <port>

  4. Start the database server by executing the appropriate script in a shell and provide a host name and port if they are needed in your configuration:

    startNetworkServer.(bat|sh) -h <host> -p <port>

  5. Optional: Rerun the sysinfo tool to check if the database server started successfully. After the server accepts connection requests, additional information is provided by the tool.

Hint: Do not use a Derby database for a production environment. If it is used for a development or test system, make sure that the database server is started manually before the WebSphere Process Server clusters start. You can complete this process by writing a simple batch file or script to keep the right order:

  1. Derby database server
  2. Deployment manager (optional)
  3. Node agents
  4. Clusters or single server

Related Information

[{"Product":{"code":"SSQH9M","label":"WebSphere Process Server"},"Business Unit":{"code":"BU053","label":"Cloud & Data Platform"},"Component":"Common DB","Platform":[{"code":"PF002","label":"AIX"},{"code":"PF010","label":"HP-UX"},{"code":"PF016","label":"Linux"},{"code":"PF027","label":"Solaris"},{"code":"PF033","label":"Windows"},{"code":"PF035","label":"z\/OS"}],"Version":"7.0;6.2;6.1.2;6.1","Edition":"","Line of Business":{"code":"LOB45","label":"Automation"}}]

Document Information

Modified date:
15 June 2018

UID

swg21313241